summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/fsi/op-fsi.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/fsi/op-fsi.bb')
-rw-r--r--meta-openpower/recipes-phosphor/fsi/op-fsi.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-openpower/recipes-phosphor/fsi/op-fsi.bb b/meta-openpower/recipes-phosphor/fsi/op-fsi.bb
index bedf65011..05d07ddb8 100644
--- a/meta-openpower/recipes-phosphor/fsi/op-fsi.bb
+++ b/meta-openpower/recipes-phosphor/fsi/op-fsi.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
-RDEPENDS_${PN} += "op-proc-control"
+RDEPENDS:${PN} += "op-proc-control"
TGTFMT_CHASSIS = "obmc-chassis-poweron@{0}.target"
TGTFMT_HOST = "obmc-host-startmin@{0}.target"
@@ -16,7 +16,7 @@ INSTFMT_SCAN = "fsi-scan@{0}.service"
FMT_SCAN_CHASSIS = "../${TMPL_SCAN}:${TGTFMT_CHASSIS}.wants/${INSTFMT_SCAN}"
FMT_SCAN_HOST = "../${TMPL_SCAN}:${TGTFMT_HOST}.wants/${INSTFMT_SCAN}"
-SYSTEMD_SERVICE_${PN} += "${TMPL_SCAN} fsi-enable.service fsi-disable.service"
+SYSTEMD_SERVICE:${PN} += "${TMPL_SCAN} fsi-enable.service fsi-disable.service"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_SCAN_CHASSIS', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_SCAN_HOST', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_SCAN_CHASSIS', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_SCAN_HOST', 'OBMC_HOST_INSTANCES')}"