summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/host/checkstop-monitor.bb')
-rw-r--r--meta-openpower/recipes-phosphor/host/checkstop-monitor.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb b/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
index ebb3a2f77..9b1b1c4c5 100644
--- a/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
+++ b/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
@@ -7,25 +7,25 @@ inherit obmc-phosphor-systemd
inherit allarch
DEPENDS += "virtual/obmc-gpio-monitor"
-RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
# For now, monitoring checkstop is the only usecase
OBMC_HOST_MONITOR_INSTANCES = "checkstop"
# Copies config file having arguments for monitoring host checkstop
# via GPIO assertion
-SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop"
+SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/checkstop"
# This package is not supplying the unit file and also this is not a native
# recipe since state-mgmt needs this package at runtime. Unsetting this below
# variable will let the build go through
-SYSTEMD_SERVICE_${PN} ?=""
+SYSTEMD_SERVICE:${PN} ?=""
# Install the override to set up a Conflicts relation
-SYSTEMD_OVERRIDE_${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
+SYSTEMD_OVERRIDE:${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
STATES = "startmin"
GPIO_MONITOR_TMPL = "phosphor-gpio-monitor@.service"
GPIO_MONITOR_TGTFMT = "phosphor-gpio-monitor@{1}.service"
CHECKSTOP_MONITOR_FMT = "../${GPIO_MONITOR_TMPL}:obmc-host-{0}@{2}.target.wants/${GPIO_MONITOR_TGTFMT}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"