summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
new file mode 100644
index 000000000..cd4f63bae
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -0,0 +1,32 @@
+SUMMARY = "OpenPOWER processor control services installation"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+
+RDEPENDS_${PN} += "op-proc-control"
+RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
+
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN}() {
+ mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
+
+ LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
+ TARGET="../op-stop-instructions@.service"
+ ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
+ TARGET="../op-cfam-reset.service"
+ ln -s $TARGET $LINK
+}
+
+pkg_prerm_${PN}() {
+ LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
+ rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
+ rm $LINK
+}