summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index c0132b80c..a30a3e46c 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -61,7 +61,12 @@ pkg_postinst_${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-reset@0.target.requires/op-reset-host-check@0.service"
TARGET="../op-reset-host-check@.service"
ln -s $TARGET $LINK
- fi
+
+ mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
+ LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
+ TARGET="../phal-import-devtree@.service"
+ ln -s $TARGET $LINK
+ fi
# If the memory preserving reboot feature is enabled, set it up
if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then
@@ -111,6 +116,9 @@ pkg_prerm_${PN}() {
LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
rm $LINK
+
+ LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
+ rm $LINK
fi
# Remove mpreboot specific units if enabled