summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/host')
-rw-r--r--meta-openpower/recipes-phosphor/host/checkstop-monitor.bb2
-rw-r--r--meta-openpower/recipes-phosphor/host/hostboot-settings.bb20
-rw-r--r--meta-openpower/recipes-phosphor/host/hostboot-settings/hb_settings110
-rw-r--r--meta-openpower/recipes-phosphor/host/hostboot-settings/hostboot-settings.service10
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb10
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-cfam-override.bb2
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-host-start.bb2
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb2
8 files changed, 5 insertions, 153 deletions
diff --git a/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb b/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
index 452cdeb87..ebb3a2f77 100644
--- a/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
+++ b/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
@@ -1,7 +1,7 @@
SUMMARY = "OpenPOWER Host checkstop monitor application"
PR = "r1"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
inherit obmc-phosphor-systemd
inherit allarch
diff --git a/meta-openpower/recipes-phosphor/host/hostboot-settings.bb b/meta-openpower/recipes-phosphor/host/hostboot-settings.bb
deleted file mode 100644
index 0a713e766..000000000
--- a/meta-openpower/recipes-phosphor/host/hostboot-settings.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SUMMARY = "OpenPower Hostboot Boot settings tool"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-
-inherit obmc-phosphor-systemd
-inherit allarch
-
-SRC_URI = "file://hb_settings"
-SYSTEMD_SERVICE_${PN} += "hostboot-settings.service"
-
-do_fetch[noexec] = "1"
-do_patch[noexec] = "1"
-do_configure[noexec] = "1"
-do_compile[noexec] = "1"
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/hb_settings ${D}${bindir}
-}
diff --git a/meta-openpower/recipes-phosphor/host/hostboot-settings/hb_settings b/meta-openpower/recipes-phosphor/host/hostboot-settings/hb_settings
deleted file mode 100644
index d75d4b74d..000000000
--- a/meta-openpower/recipes-phosphor/host/hostboot-settings/hb_settings
+++ /dev/null
@@ -1,110 +0,0 @@
-#!/bin/sh
-# Copyright 2018 IBM Corp
-# SPDX-License-Identifier: Apache-2.0
-# Authored May 2018, Joel Stanley <joel@jms.id.au>
-#
-# This script sets the SIO scratch registers 0x2D in order to configure
-# hostboot. It supports boot flags v1 as defined in hostboot source:
-# src/usr/initservice/bootconfig/bootconfig_ast2400.C
-# src/usr/console/ast2400.C
-#
-# BOOT_FLAGS_VERSION_REG = 0x28,
-# Serial config reg: 0x2d
-# Serial config mask: 0xc0
-#
-# NONE = 0x00, // No output selected
-# SELECT_SUART = 0x40, // SIO Uart
-# SELECT_VUART = 0x80, // SOL virtual uart
-# RESERVED = 0xc0, // Reserved
-
-
-SYSFS_SIO=/sys/devices/platform/ahb/ahb:apb/1e789000.lpc/1e789080.lpc-host/1e789080.lpc-host:regs
-SYSFS_SIO28=$SYSFS_SIO/sio_28
-SYSFS_SIO2D=$SYSFS_SIO/sio_2d
-
-FLAGS_VERSION1=$((0x42))
-
-usage()
-{
- echo "usage: hb_settings [[-u|--uart vuart|suart|none] | [-s|--show] | [-h]]"
-}
-
-show_regs()
-{
- SIO28=$(cat $SYSFS_SIO28)
- SIO2D=$(cat $SYSFS_SIO2D)
-
- case $SIO28 in
- $FLAGS_VERSION1)
- echo "Boot flags version 1"
- ;;
- * )
- echo "Unknown boot flags version"
- ;;
- esac
-
- case $(($SIO2D >> 6)) in
- 0)
- echo "Hostboot serial output disabled"
- ;;
- 1)
- echo "Hostboot serial output on SUART"
- ;;
- 2)
- echo "Hostboot serial output on VUART"
- ;;
- 3)
- echo "Reserved value"
- ;;
- * )
- echo "Invalid uart value"
- ;;
- esac
-}
-
-set_regs()
-{
- case $uart in
- suart)
- echo "Hostboot serial output on SUART"
- VAL=0x40
- ;;
- vuart)
- echo "Hostboot serial output on VUART"
- VAL=0x80
- ;;
- none)
- echo "Hostboot serial output disabled"
- VAL=0x00
- ;;
- * )
- echo "Invalid uart value"
- usage
- exit 1
- esac
-
- echo $FLAGS_VERSION1 > $SYSFS_SIO28
- echo $VAL > $SYSFS_SIO2D
-}
-
-while [ "$1" != "" ]; do
- case $1 in
- -u | --uart) shift
- uart=$1
- set_regs
- exit
- ;;
- -s | --show ) show_regs
- exit
- ;;
- -h | --help ) usage
- exit
- ;;
- * ) usage
- exit 1
- esac
- shift
-done
-
-usage
-exit 0
diff --git a/meta-openpower/recipes-phosphor/host/hostboot-settings/hostboot-settings.service b/meta-openpower/recipes-phosphor/host/hostboot-settings/hostboot-settings.service
deleted file mode 100644
index 9ce81d79b..000000000
--- a/meta-openpower/recipes-phosphor/host/hostboot-settings/hostboot-settings.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Hostboot Boot Settings
-
-[Service]
-Type=oneshot
-RemainAfterExit=true
-ExecStart=/usr/bin/hb_settings --uart vuart
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 05d6d90df..33ac60c6c 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit autotools obmc-phosphor-utils pkgconfig pythonnative
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "16ab00cb9383b17b8dd033a1cb300e2a013d55b1"
+SRCREV = "60db8b147dad15890ffed21230537cd8d4898efc"
DEPENDS += " \
autoconf-archive-native \
@@ -23,13 +23,6 @@ DEPENDS += " \
# For libpdbg, provided by the pdbg package
DEPENDS += "pdbg"
-# For now, explicitly depend on the pdbg package for the pdbg binary at runtime
-# (as documentation). This will be removed shortly when we only depend on
-# libpdbg; the pdbg package will automatically injected into RDEPENDS by
-# bitbake as it is in DEPENDS and openpower-proc-nmi has a runtime link
-# dependency on libpdbg.
-RDEPENDS_${PN} += "pdbg"
-
TEMPLATE = "pcie-poweroff@.service"
INSTANCE_FORMAT = "pcie-poweroff@{}.service"
INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}"
@@ -38,5 +31,4 @@ SYSTEMD_SERVICE_${PN} = "${TEMPLATE} ${INSTANCES}"
SYSTEMD_SERVICE_${PN} += " \
xyz.openbmc_project.Control.Host.NMI.service \
- nmi.service \
"
diff --git a/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb b/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
index e395841ba..769a1348d 100644
--- a/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
@@ -2,7 +2,7 @@ SUMMARY = "POWER9 CFAM override"
DESCRIPTION = "Applies user CFAM register overrides from file"
PR = "r1"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
inherit obmc-phosphor-systemd
diff --git a/meta-openpower/recipes-phosphor/host/p9-host-start.bb b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
index b9110010e..374359838 100644
--- a/meta-openpower/recipes-phosphor/host/p9-host-start.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
@@ -2,7 +2,7 @@ SUMMARY = "POWER9 start host"
DESCRIPTION = "Service to start POWER9 IPL through SBE"
PR = "r1"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
inherit obmc-phosphor-systemd
diff --git a/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb b/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb
index 43efeab24..29167b0e1 100644
--- a/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb
@@ -2,7 +2,7 @@ SUMMARY = "POWER9 VCS workaround"
DESCRIPTION = "Apply fixes over FSI to POWER9 CPUs prior to host power on"
PR = "r1"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
inherit obmc-phosphor-systemd