summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb')
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
index 711b7e6a3..142c09d8d 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
@@ -7,17 +7,19 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
inherit autotools pkgconfig
inherit obmc-phosphor-ipmiprovider-symlink
-inherit pythonnative
+inherit python3native
-require ${PN}.inc
+require ${BPN}.inc
DEPENDS += "phosphor-ipmi-host"
DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "sdbusplus"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
+DEPENDS += "${PYTHON_PN}-mako-native"
+DEPENDS += "${PYTHON_PN}-pyyaml-native"
DEPENDS += "phosphor-logging"
DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
-DEPENDS += "sdbus++-native"
DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
TARGET_CFLAGS += "-fpic"