summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/ipmi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/ipmi')
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
new file mode 100644
index 000000000..ccdf2cd6a
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Phosphor IPMI plugin for the Host I/O Mapping Protocol"
+HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-flash"
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ff331e820fda701d36a8f0efc98adc58"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-ipmiprovider-symlink
+
+DEPENDS += "phosphor-ipmi-host"
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "phosphor-logging"
+DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
+DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
+
+TARGET_CFLAGS += "-fpic"
+
+HOSTIPMI_PROVIDER_LIBRARY += "libhiomap.so"
+
+S = "${WORKDIR}/git"
+
+SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-flash"
+SRCREV = "04d75136b44ba2373e6ec455a4c333910d6d1bd7"
+
+FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"