summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/ipmi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/ipmi')
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc2
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb10
3 files changed, 9 insertions, 7 deletions
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
index 0b1e52b48..f0d54ea54 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
@@ -10,7 +10,7 @@ inherit obmc-phosphor-ipmiprovider-symlink
DEPENDS += "phosphor-ipmi-host"
DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "sdbusplus"
DEPENDS += "phosphor-logging"
DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
@@ -22,7 +22,7 @@ HOSTIPMI_PROVIDER_LIBRARY += "libhiomap.so"
S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-flash"
-SRCREV = "d4b7f5e4819aa6e3ddb165a80149dd1a1c1649d7"
+SRCREV = "a182dce8b97c4ca17832b4cc47c7a7b947291466"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc
index 81a901c74..7cfe609f4 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
-SRCREV = "36ae8e5c4256b751ada4d6a2c9486c78d03ecba9"
+SRCREV = "9975ae919e4cb8968639d9f953912e6c73205c44"
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
index 711b7e6a3..142c09d8d 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
@@ -7,17 +7,19 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
inherit autotools pkgconfig
inherit obmc-phosphor-ipmiprovider-symlink
-inherit pythonnative
+inherit python3native
-require ${PN}.inc
+require ${BPN}.inc
DEPENDS += "phosphor-ipmi-host"
DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "sdbusplus"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
+DEPENDS += "${PYTHON_PN}-mako-native"
+DEPENDS += "${PYTHON_PN}-pyyaml-native"
DEPENDS += "phosphor-logging"
DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
-DEPENDS += "sdbus++-native"
DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
TARGET_CFLAGS += "-fpic"