summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb')
-rw-r--r--meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb28
1 files changed, 19 insertions, 9 deletions
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
index dca85731b..4a6cc049f 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
@@ -1,22 +1,32 @@
-inherit meson systemd
+HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags"
+SUMMARY = "Hardware Diagnostics for POWER Systems"
+
+DESCRIPTION = \
+ "In the event of a system fatal error reported by the internal system \
+ hardware (processor chips, memory chips, I/O chips, system memory, etc.), \
+ POWER Systems have the ability to diagnose the root cause of the failure \
+ and perform any service action needed to avoid repeated system failures."
-SUMMARY = "ATTN and HwDiags Support"
-DESCRIPTION = "Attention Handler and Hardware Diagnostics"
+PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+inherit meson systemd
+
+S = "${WORKDIR}/git"
+
SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
+SRCREV = "2d5c63d90c14793e333c4eee6d0b8002fdf0c7ba"
SYSTEMD_SERVICE_${PN} = "attn_handler.service"
-PV = "0.1+git${SRCPV}"
-SRCREV = "8af9e46f43d2ffa030275d17716571d4fcc8ad18"
-
-S = "${WORKDIR}/git"
DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \
nlohmann-json"
-FILES_${PN} += "${UNITDIR}/attn_handler.service"
-
# This is required so that libhei is installed with the chip data files.
RDEPENDS_${PN} += "openpower-libhei"
+
+# Conditionally pull in PHAL APIs, if available.
+PACKAGECONFIG ??= "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}"
+PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, pdata"
+