summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb')
-rw-r--r--meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb24
1 files changed, 15 insertions, 9 deletions
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
index fdcff05f1..94cae40ec 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
@@ -1,22 +1,28 @@
-inherit meson systemd
+HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags"
+SUMMARY = "Hardware Diagnostics for POWER Systems"
+
+DESCRIPTION = \
+ "In the event of a system fatal error reported by the internal system \
+ hardware (processor chips, memory chips, I/O chips, system memory, etc.), \
+ POWER Systems have the ability to diagnose the root cause of the failure \
+ and perform any service action needed to avoid repeated system failures."
-SUMMARY = "ATTN and HwDiags Support"
-DESCRIPTION = "Attention Handler and Hardware Diagnostics"
+PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
+inherit meson systemd
-SYSTEMD_SERVICE_${PN} = "attn_handler.service"
-PV = "0.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
SRCREV = "0b8368cb0aa251032eb18b5c938d009e27f0b152"
-S = "${WORKDIR}/git"
+SYSTEMD_SERVICE_${PN} = "attn_handler.service"
+FILES_${PN} += "${UNITDIR}/attn_handler.service"
DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \
nlohmann-json"
-FILES_${PN} += "${UNITDIR}/attn_handler.service"
-
# This is required so that libhei is installed with the chip data files.
RDEPENDS_${PN} += "openpower-libhei"