summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native_git.bb')
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native_git.bb
new file mode 100644
index 000000000..723d59e04
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-example-native_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "OpenPower OCC Control with example occ sensor IDs"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+inherit native
+require openpower-occ-control.inc
+inherit openpower-occ-control
+
+PROVIDES += "virtual/openpower-occ-control-config-native"
+
+S = "${WORKDIR}/git"
+
+# Copies example occ sensor ID yaml file
+do_install() {
+ SRC=${S}
+ install -d ${YAML_DEST}/
+ install -D ${SRC}/example/occ_sensor.yaml ${YAML_DEST}/occ_sensor.yaml
+}