summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb')
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb32
1 files changed, 16 insertions, 16 deletions
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index 210b5fcc2..440829175 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -13,15 +13,15 @@ inherit autotools \
require ${BPN}.inc
SRC_URI += "file://occ-active.sh"
-do_install_append() {
+do_install:append() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/occ-active.sh \
${D}${bindir}/occ-active.sh
}
-DBUS_SERVICE_${PN} += "org.open_power.OCC.Control.service"
-SYSTEMD_SERVICE_${PN} += "op-occ-enable@.service"
-SYSTEMD_SERVICE_${PN} += "op-occ-disable@.service"
+DBUS_SERVICE:${PN} += "org.open_power.OCC.Control.service"
+SYSTEMD_SERVICE:${PN} += "op-occ-enable@.service"
+SYSTEMD_SERVICE:${PN} += "op-occ-disable@.service"
DEPENDS += "virtual/${PN}-config-native"
DEPENDS += " \
@@ -37,13 +37,13 @@ DEPENDS += " \
${PYTHON_PN}-mako-native \
"
-RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN} += "phosphor-state-manager-obmc-targets"
EXTRA_OECONF = " \
YAML_PATH=${STAGING_DATADIR_NATIVE}/${PN} \
PS_DERATING_FACTOR=${POWER_SUPPLY_DERATING_FACTOR} \
"
-EXTRA_OECONF_append = "${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'i2c-occ', ' --enable-i2c-occ', '', d)}"
+EXTRA_OECONF:append = "${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'i2c-occ', ' --enable-i2c-occ', '', d)}"
OCC_ENABLE = "enable"
OCC_DISABLE = "disable"
@@ -55,8 +55,8 @@ OCC_TMPL = "op-occ-{0}@.service"
HOST_TGTFMT = "obmc-host-{1}@{2}.target"
OCC_INSTFMT = "op-occ-{0}@{2}.service"
HOST_OCC_FMT = "../${OCC_TMPL}:${HOST_TGTFMT}.wants/${OCC_INSTFMT}"
-SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_ENABLE', 'HOST_START', 'OBMC_HOST_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_DISABLE', 'HOST_STOP', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_ENABLE', 'HOST_START', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_DISABLE', 'HOST_STOP', 'OBMC_HOST_INSTANCES')}"
# Set the occ disable service to be executed on host error
HOST_ERROR_TARGETS = "crash timeout"
@@ -66,27 +66,27 @@ HOST_ERROR_TGTFMT = "obmc-host-{0}@{1}.target"
OCC_DISABLE_INSTFMT = "op-occ-disable@{1}.service"
HOST_ERROR_FMT = "../${OCC_DISABLE_TMPL}:${HOST_ERROR_TGTFMT}.wants/${OCC_DISABLE_INSTFMT}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'HOST_ERROR_FMT', 'HOST_ERROR_TARGETS', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'HOST_ERROR_FMT', 'HOST_ERROR_TARGETS', 'OBMC_HOST_INSTANCES')}"
S = "${WORKDIR}/git"
# Remove packages not required for native build
-DEPENDS_remove_class-native = " \
+DEPENDS:remove:class-native = " \
phosphor-logging \
systemd \
sdbusplus \
virtual/${PN}-config-native \
"
-RDEPENDS_${PN}_remove_class-native += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN}:remove:class-native += "phosphor-state-manager-obmc-targets"
# Remove packages not required for native SDK build
-DEPENDS_remove_class-nativesdk = " \
+DEPENDS:remove:class-nativesdk = " \
phosphor-logging \
systemd \
sdbusplus \
virtual/${PN}-config-native \
"
-RDEPENDS_${PN}_remove_class-nativesdk += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN}:remove:class-nativesdk += "phosphor-state-manager-obmc-targets"
# Provide a means to enable/disable install_error_yaml feature
PACKAGECONFIG ??= "install_error_yaml"
@@ -97,10 +97,10 @@ PACKAGECONFIG[install_error_yaml] = "\
"
# Enable install_error_yaml during native and native SDK build
-PACKAGECONFIG_add_class-native = "install_error_yaml"
-PACKAGECONFIG_add_class-nativesdk = "install_error_yaml"
+PACKAGECONFIG:add:class-native = "install_error_yaml"
+PACKAGECONFIG:add:class-nativesdk = "install_error_yaml"
# Disable install_error_yaml during target build
-PACKAGECONFIG_remove_class-target = "install_error_yaml"
+PACKAGECONFIG:remove:class-target = "install_error_yaml"
BBCLASSEXTEND += "native nativesdk"