summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb')
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index aaab247f7..210b5fcc2 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -10,7 +10,7 @@ inherit autotools \
python3native \
phosphor-dbus-yaml
-require ${PN}.inc
+require ${BPN}.inc
SRC_URI += "file://occ-active.sh"
do_install_append() {
@@ -26,7 +26,7 @@ SYSTEMD_SERVICE_${PN} += "op-occ-disable@.service"
DEPENDS += "virtual/${PN}-config-native"
DEPENDS += " \
sdbusplus \
- sdbusplus-native \
+ ${PYTHON_PN}-sdbus++-native \
phosphor-logging \
phosphor-dbus-interfaces \
autoconf-archive-native \
@@ -50,11 +50,11 @@ OCC_DISABLE = "disable"
HOST_START = "startmin"
HOST_STOP = "stop"
-# Ensure host-stop and host-startmin targets require needed occ states
+# Ensure host-stop and host-startmin targets wants needed occ states
OCC_TMPL = "op-occ-{0}@.service"
HOST_TGTFMT = "obmc-host-{1}@{2}.target"
OCC_INSTFMT = "op-occ-{0}@{2}.service"
-HOST_OCC_FMT = "../${OCC_TMPL}:${HOST_TGTFMT}.requires/${OCC_INSTFMT}"
+HOST_OCC_FMT = "../${OCC_TMPL}:${HOST_TGTFMT}.wants/${OCC_INSTFMT}"
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_ENABLE', 'HOST_START', 'OBMC_HOST_INSTANCES')}"
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_DISABLE', 'HOST_STOP', 'OBMC_HOST_INSTANCES')}"
@@ -74,6 +74,7 @@ S = "${WORKDIR}/git"
DEPENDS_remove_class-native = " \
phosphor-logging \
systemd \
+ sdbusplus \
virtual/${PN}-config-native \
"
RDEPENDS_${PN}_remove_class-native += "phosphor-state-manager-obmc-targets"
@@ -82,6 +83,7 @@ RDEPENDS_${PN}_remove_class-native += "phosphor-state-manager-obmc-targets"
DEPENDS_remove_class-nativesdk = " \
phosphor-logging \
systemd \
+ sdbusplus \
virtual/${PN}-config-native \
"
RDEPENDS_${PN}_remove_class-nativesdk += "phosphor-state-manager-obmc-targets"