summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower/recipes-phosphor')
-rw-r--r--meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb5
-rw-r--r--meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service1
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb53
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb3
-rw-r--r--meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc2
7 files changed, 55 insertions, 13 deletions
diff --git a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
index 13cef9508..7c51ad8e8 100644
--- a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
+++ b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
@@ -42,6 +42,7 @@ EXTRA_OEMESON += " \
DEPENDS += " \
cli11 \
+ dbus \
openssl \
phosphor-dbus-interfaces \
phosphor-logging \
@@ -52,11 +53,13 @@ RDEPENDS_${PN} += " \
virtual-obmc-image-manager \
"
+FILES_${PN} += "${datadir}/dbus-1/system.d/org.open_power.Software.Host.Updater.conf"
+
S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
-SRCREV = "847f54c033075af5fb4aa34864d2c07585073794"
+SRCREV = "0529d284b008fa4b4ff9512da5f375decfd62740"
DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
diff --git a/meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service b/meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service
index 825275ae7..aa12be325 100644
--- a/meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service
+++ b/meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service
@@ -1,5 +1,6 @@
[Unit]
Description=Start host%i SBE
+Wants=obmc-host-start-pre@%i.target
After=obmc-host-start-pre@%i.target
Wants=obmc-host-starting@%i.target
Before=obmc-host-starting@%i.target
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 521ff02b9..cae79bef0 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -17,11 +17,16 @@ pkg_postinst_${PN}() {
mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires
mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants
LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
TARGET="../op-stop-instructions@.service"
ln -s $TARGET $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/op-stop-instructions@0.service"
+ TARGET="../op-stop-instructions@.service"
+ ln -s $TARGET $LINK
+
LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
TARGET="../op-cfam-reset.service"
ln -s $TARGET $LINK
@@ -42,16 +47,38 @@ pkg_postinst_${PN}() {
TARGET="../op-continue-mpreboot@.service"
ln -s $TARGET $LINK
- LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
- TARGET="../op-enter-mpreboot@.service"
- ln -s $TARGET $LINK
-
- # Only install phal reinit service if phal enabled
+ # Only install certain units if phal enabled
if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.requires
LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
TARGET="../phal-reinit-devtree.service"
ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
+ TARGET="../proc-pre-poweroff@.service"
+ ln -s $TARGET $LINK
+
+ # on phal systems, obmc-host-crash@.target is used for MPIPL
+ mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.requires
+ LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-force-warm-reboot@0.target"
+ TARGET="../obmc-host-force-warm-reboot@.target"
+ ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/op-enter-mpreboot@0.service"
+ TARGET="../op-enter-mpreboot@.service"
+ ln -s $TARGET $LINK
+
+ # ensure diagnostic mode is shown for MPIPL
+ LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-diagnostic-mode@0.target"
+ TARGET="../obmc-host-diagnostic-mode@.target"
+ ln -s $TARGET $LINK
+ else
+ # If not phal, default to quiesce target in crash target to support
+ # older system designs like witherspoon
+ mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.wants
+ LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/obmc-host-quiesce@0.target"
+ TARGET="../obmc-host-quiesce@.target"
+ ln -s $TARGET $LINK
fi
}
@@ -69,12 +96,22 @@ pkg_prerm_${PN}() {
fi
LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
rm $LINK
- LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
- rm $LINK
- # Only phal reinit service if phal enabled
+ # Remove phal specific units if enabled
if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
rm $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
+ rm $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-force-warm-reboot@0.target"
+ rm $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/op-enter-mpreboot@0.service"
+ rm $LINK
+ else
+ LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/obmc-host-quiesce@0.target"
+ rm $LINK
fi
}
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 1fc98410d..8bb12b88a 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit autotools obmc-phosphor-utils pkgconfig
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "31228b9b4bc4310c97846bb35730fa96c060d47b"
+SRCREV = "ea0fb6fc4cc843122809c21f9f41048f394b40e3"
DEPENDS += " \
autoconf-archive-native \
@@ -37,4 +37,5 @@ SYSTEMD_SERVICE_${PN} += " \
op-continue-mpreboot@.service \
op-enter-mpreboot@.service \
${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'phal-reinit-devtree.service', '', d)} \
+ ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'proc-pre-poweroff@.service', '', d)} \
"
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
index 319657aff..446bc8272 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
@@ -9,7 +9,7 @@ SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
SYSTEMD_SERVICE_${PN} = "attn_handler.service"
PV = "0.1+git${SRCPV}"
-SRCREV = "021dab3c73eab84d621500d8388392f85f73e4f3"
+SRCREV = "dc5b0ff1d62ffbf232bde9753d1c071e2ff64069"
S = "${WORKDIR}/git"
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb
index 8d15cd520..ab73eb056 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
SRC_URI = "git://github.com/openbmc/openpower-libhei"
PV = "0.1+git${SRCPV}"
-SRCREV = "d280cca793349d2cd06efbbef5db65c9bae34b98"
+SRCREV = "fc4aa5ecebfbc8d6fab8b0d88d3d9c1bbbcde8ab"
S = "${WORKDIR}/git"
diff --git a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc
index 640107b60..64a621e11 100644
--- a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc
+++ b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/openpower-vpd-parser"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/openpower-vpd-parser"
-SRCREV = "8589375ff66d10295d609cca53cdf2f9f12a5472"
+SRCREV = "9094d4f6453ca8fcca2d6d62967631cb8bedbcc6"