summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb35
-rw-r--r--meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-fru-properties-mrw.yaml37
-rw-r--r--meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-fru-mrw.yaml130
-rw-r--r--meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-volatile-sensor-mrw.yaml16
-rw-r--r--meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-occ-active-sensor-mrw.yaml17
5 files changed, 235 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb
new file mode 100644
index 000000000..52ac769ab
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Shared OpenPOWER configuration"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+
+SRC_URI = " \
+ file://ipmi-fru-properties-mrw.yaml \
+ file://ipmi-hostboot-fru-mrw.yaml \
+ file://ipmi-hostboot-volatile-sensor-mrw.yaml \
+ file://ipmi-occ-active-sensor-mrw.yaml \
+ "
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -m 0644 -D ipmi-fru-properties-mrw.yaml \
+ ${D}${datadir}/${BPN}/ipmi-fru-properties-mrw.yaml
+ install -m 0644 -D ipmi-hostboot-fru-mrw.yaml \
+ ${D}${datadir}/${BPN}/ipmi-hostboot-fru-mrw.yaml
+ install -m 0644 -D ipmi-hostboot-volatile-sensor-mrw.yaml \
+ ${D}${datadir}/${BPN}/ipmi-hostboot-volatile-sensor-mrw.yaml
+ install -m 0644 -D ipmi-occ-active-sensor-mrw.yaml \
+ ${D}${datadir}/${BPN}/ipmi-occ-active-sensor-mrw.yaml
+}
+
+FILES_${PN}-dev = " \
+ ${datadir}/${BPN}/ipmi-fru-properties-mrw.yaml \
+ ${datadir}/${BPN}/ipmi-hostboot-fru-mrw.yaml \
+ ${datadir}/${BPN}/ipmi-hostboot-volatile-sensor-mrw.yaml \
+ ${datadir}/${BPN}/ipmi-occ-active-sensor-mrw.yaml \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
diff --git a/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-fru-properties-mrw.yaml b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-fru-properties-mrw.yaml
new file mode 100644
index 000000000..6e80a9942
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-fru-properties-mrw.yaml
@@ -0,0 +1,37 @@
+# A template for generating extra-properties.yaml for ipmi-fru-parser, from the
+# MRW with gen_fru_properties.pl
+DIMM:
+ xyz.openbmc_project.Inventory.Decorator.Cacheable:
+ Cached: 'false'
+ xyz.openbmc_project.Inventory.Decorator.Replaceable:
+ FieldReplaceable: 'false'
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
+NODE:
+ xyz.openbmc_project.Inventory.Decorator.Cacheable:
+ Cached: 'false'
+ xyz.openbmc_project.Inventory.Decorator.Replaceable:
+ FieldReplaceable: 'false'
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
+PROC:
+ xyz.openbmc_project.Inventory.Decorator.Cacheable:
+ Cached: 'false'
+ xyz.openbmc_project.Inventory.Decorator.Replaceable:
+ FieldReplaceable: 'false'
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
+SYS:
+ xyz.openbmc_project.Inventory.Decorator.Cacheable:
+ Cached: 'false'
+ xyz.openbmc_project.Inventory.Decorator.Replaceable:
+ FieldReplaceable: 'false'
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
+TPM:
+ xyz.openbmc_project.Inventory.Decorator.Cacheable:
+ Cached: 'false'
+ xyz.openbmc_project.Inventory.Decorator.Replaceable:
+ FieldReplaceable: 'true'
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
diff --git a/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-fru-mrw.yaml b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-fru-mrw.yaml
new file mode 100644
index 000000000..3f6a73989
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-fru-mrw.yaml
@@ -0,0 +1,130 @@
+DIMM:
+ EntityID: 32
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Product
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Product
+ Model:
+ IPMIFruProperty: Model Number
+ IPMIFruSection: Product
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Product
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Product
+ xyz.openbmc_project.Inventory.Decorator.Revision:
+ Version:
+ IPMIFruProperty: Version
+ IPMIFruSection: Product
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Product
+ xyz.openbmc_project.Inventory.Item.Dimm:
+MEMBUFF:
+ EntityID: 8
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item.MemoryBuffer:
+NODE:
+ AssociatedTypes:
+ - SYS
+ EntityID: 7
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item.Board:
+PROC:
+ EntityID: 3
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Decorator.Revision:
+ Version:
+ IPMIFruProperty: Custom Field 2
+ IPMIFruSection: Board
+ IPMIFruValueDelimiter: '58'
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item.Cpu:
+SYS:
+ EntityID: 7
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ Model:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Chassis
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Chassis
+ xyz.openbmc_project.Inventory.Item.System:
+TPM:
+ EntityID: 176
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item.Tpm:
diff --git a/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-volatile-sensor-mrw.yaml b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-volatile-sensor-mrw.yaml
new file mode 100644
index 000000000..1fcf935f9
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-volatile-sensor-mrw.yaml
@@ -0,0 +1,16 @@
+hb_volatile_sensor:
+ interfaces:
+ xyz.openbmc_project.Object.Enable:
+ Enabled:
+ Offsets:
+ 0:
+ assert: false
+ type: bool
+ 1:
+ assert: true
+ type: bool
+ mutability: Mutability::Write|Mutability::Read
+ path: /org/open_power/control/volatile
+ readingType: assertion
+ sensorNamePattern: nameLeaf
+ serviceInterface: org.freedesktop.DBus.Properties
diff --git a/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-occ-active-sensor-mrw.yaml b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-occ-active-sensor-mrw.yaml
new file mode 100644
index 000000000..5470c42da
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-occ-active-sensor-mrw.yaml
@@ -0,0 +1,17 @@
+occ_active_sensor:
+ interfaces:
+ org.open_power.OCC.Status:
+ OccActive:
+ Offsets:
+ 0:
+ assert: 'false'
+ deassert: 'true'
+ type: bool
+ 1:
+ assert: 'true'
+ deassert: 'false'
+ type: bool
+ mutability: Mutability::Write|Mutability::Read
+ readingType: assertion
+ sensorNamePattern: nameLeaf
+ serviceInterface: org.freedesktop.DBus.Properties