summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/classes/openpower-software-manager-ubi.bbclass4
-rw-r--r--meta-openpower/recipes-bsp/pdbg/pdbg_2.1.bb (renamed from meta-openpower/recipes-bsp/pdbg/pdbg_2.0.bb)4
-rw-r--r--meta-openpower/recipes-devtools/hostboot/hostboot-debug-tools.bb21
-rw-r--r--meta-openpower/recipes-phosphor/bmcweb/bmcweb_%.bbappend2
-rw-r--r--meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb35
-rw-r--r--meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-fru-properties-mrw.yaml37
-rw-r--r--meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-fru-mrw.yaml130
-rw-r--r--meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-volatile-sensor-mrw.yaml16
-rw-r--r--meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-occ-active-sensor-mrw.yaml17
-rw-r--r--meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.service13
-rw-r--r--meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.sh46
-rw-r--r--meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb22
13 files changed, 343 insertions, 6 deletions
diff --git a/meta-openpower/classes/openpower-software-manager-ubi.bbclass b/meta-openpower/classes/openpower-software-manager-ubi.bbclass
index ae6c3880b..5b60384f1 100644
--- a/meta-openpower/classes/openpower-software-manager-ubi.bbclass
+++ b/meta-openpower/classes/openpower-software-manager-ubi.bbclass
@@ -3,8 +3,8 @@ SRC_URI += "file://obmc-flash-bios"
PACKAGECONFIG_append = " ubifs_layout"
do_install_append() {
- install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/obmc-flash-bios ${D}${sbindir}/obmc-flash-bios
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/obmc-flash-bios ${D}${bindir}/obmc-flash-bios
}
SYSTEMD_SERVICE_${PN} += " \
diff --git a/meta-openpower/recipes-bsp/pdbg/pdbg_2.0.bb b/meta-openpower/recipes-bsp/pdbg/pdbg_2.1.bb
index 8c1232c56..b4f15f82d 100644
--- a/meta-openpower/recipes-bsp/pdbg/pdbg_2.0.bb
+++ b/meta-openpower/recipes-bsp/pdbg/pdbg_2.1.bb
@@ -3,10 +3,10 @@ DESCRIPTION = "pdbg allows JTAG-like debugging of the host POWER processors"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
-PV = "2.0+git${SRCPV}"
+PV = "2.1+git${SRCPV}"
SRC_URI += "git://github.com/open-power/pdbg.git"
-SRCREV = "854c4c5facff43af9e0fe5d7062b58f631987b0b"
+SRCREV = "2463be165d7eaa50b648c343e410d851edfb70ce"
DEPENDS += "dtc-native"
diff --git a/meta-openpower/recipes-devtools/hostboot/hostboot-debug-tools.bb b/meta-openpower/recipes-devtools/hostboot/hostboot-debug-tools.bb
new file mode 100644
index 000000000..f1265bda6
--- /dev/null
+++ b/meta-openpower/recipes-devtools/hostboot/hostboot-debug-tools.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Recipe for enabling hostboot-debug-tools"
+DESCRIPTION = "Support to enable running hostboot-debug-tools"
+LICENSE = "Apache-2.0"
+PR = "r1"
+
+inherit allarch
+
+RDEPENDS_${PN} = " \
+ perl perl-module-pod-text perl-module-lib \
+ perl-module-constant \
+ perl-module-errno perl-module-fcntl \
+ perl-module-file-basename perl-module-file-copy \
+ perl-module-file-find perl-module-file-glob \
+ perl-module-file-path perl-module-file-spec \
+ perl-module-file-temp perl-module-getopt-long \
+ perl-module-re perl-module-text-wrap \
+ perl-module-posix perl-module-bigint \
+ perl-module-integer \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
diff --git a/meta-openpower/recipes-phosphor/bmcweb/bmcweb_%.bbappend b/meta-openpower/recipes-phosphor/bmcweb/bmcweb_%.bbappend
index 0765ddffb..1035bf169 100644
--- a/meta-openpower/recipes-phosphor/bmcweb/bmcweb_%.bbappend
+++ b/meta-openpower/recipes-phosphor/bmcweb/bmcweb_%.bbappend
@@ -1 +1 @@
-EXTRA_OECMAKE_df-openpower += "-DBMCWEB_ENABLE_REDFISH_DBUS_LOG_ENTRIES=ON"
+EXTRA_OECMAKE_append_df-openpower = " -DBMCWEB_ENABLE_REDFISH_DBUS_LOG_ENTRIES=ON"
diff --git a/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb
new file mode 100644
index 000000000..52ac769ab
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Shared OpenPOWER configuration"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch
+
+SRC_URI = " \
+ file://ipmi-fru-properties-mrw.yaml \
+ file://ipmi-hostboot-fru-mrw.yaml \
+ file://ipmi-hostboot-volatile-sensor-mrw.yaml \
+ file://ipmi-occ-active-sensor-mrw.yaml \
+ "
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -m 0644 -D ipmi-fru-properties-mrw.yaml \
+ ${D}${datadir}/${BPN}/ipmi-fru-properties-mrw.yaml
+ install -m 0644 -D ipmi-hostboot-fru-mrw.yaml \
+ ${D}${datadir}/${BPN}/ipmi-hostboot-fru-mrw.yaml
+ install -m 0644 -D ipmi-hostboot-volatile-sensor-mrw.yaml \
+ ${D}${datadir}/${BPN}/ipmi-hostboot-volatile-sensor-mrw.yaml
+ install -m 0644 -D ipmi-occ-active-sensor-mrw.yaml \
+ ${D}${datadir}/${BPN}/ipmi-occ-active-sensor-mrw.yaml
+}
+
+FILES_${PN}-dev = " \
+ ${datadir}/${BPN}/ipmi-fru-properties-mrw.yaml \
+ ${datadir}/${BPN}/ipmi-hostboot-fru-mrw.yaml \
+ ${datadir}/${BPN}/ipmi-hostboot-volatile-sensor-mrw.yaml \
+ ${datadir}/${BPN}/ipmi-occ-active-sensor-mrw.yaml \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
diff --git a/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-fru-properties-mrw.yaml b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-fru-properties-mrw.yaml
new file mode 100644
index 000000000..6e80a9942
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-fru-properties-mrw.yaml
@@ -0,0 +1,37 @@
+# A template for generating extra-properties.yaml for ipmi-fru-parser, from the
+# MRW with gen_fru_properties.pl
+DIMM:
+ xyz.openbmc_project.Inventory.Decorator.Cacheable:
+ Cached: 'false'
+ xyz.openbmc_project.Inventory.Decorator.Replaceable:
+ FieldReplaceable: 'false'
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
+NODE:
+ xyz.openbmc_project.Inventory.Decorator.Cacheable:
+ Cached: 'false'
+ xyz.openbmc_project.Inventory.Decorator.Replaceable:
+ FieldReplaceable: 'false'
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
+PROC:
+ xyz.openbmc_project.Inventory.Decorator.Cacheable:
+ Cached: 'false'
+ xyz.openbmc_project.Inventory.Decorator.Replaceable:
+ FieldReplaceable: 'false'
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
+SYS:
+ xyz.openbmc_project.Inventory.Decorator.Cacheable:
+ Cached: 'false'
+ xyz.openbmc_project.Inventory.Decorator.Replaceable:
+ FieldReplaceable: 'false'
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
+TPM:
+ xyz.openbmc_project.Inventory.Decorator.Cacheable:
+ Cached: 'false'
+ xyz.openbmc_project.Inventory.Decorator.Replaceable:
+ FieldReplaceable: 'true'
+ xyz.openbmc_project.Inventory.Item:
+ Present: 'true'
diff --git a/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-fru-mrw.yaml b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-fru-mrw.yaml
new file mode 100644
index 000000000..3f6a73989
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-fru-mrw.yaml
@@ -0,0 +1,130 @@
+DIMM:
+ EntityID: 32
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Product
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Product
+ Model:
+ IPMIFruProperty: Model Number
+ IPMIFruSection: Product
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Product
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Product
+ xyz.openbmc_project.Inventory.Decorator.Revision:
+ Version:
+ IPMIFruProperty: Version
+ IPMIFruSection: Product
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Product
+ xyz.openbmc_project.Inventory.Item.Dimm:
+MEMBUFF:
+ EntityID: 8
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item.MemoryBuffer:
+NODE:
+ AssociatedTypes:
+ - SYS
+ EntityID: 7
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item.Board:
+PROC:
+ EntityID: 3
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Decorator.Revision:
+ Version:
+ IPMIFruProperty: Custom Field 2
+ IPMIFruSection: Board
+ IPMIFruValueDelimiter: '58'
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item.Cpu:
+SYS:
+ EntityID: 7
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ Model:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Chassis
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Chassis
+ xyz.openbmc_project.Inventory.Item.System:
+TPM:
+ EntityID: 176
+ Interfaces:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruProperty: Mfg Date
+ IPMIFruSection: Board
+ Manufacturer:
+ IPMIFruProperty: Manufacturer
+ IPMIFruSection: Board
+ PartNumber:
+ IPMIFruProperty: Part Number
+ IPMIFruSection: Board
+ SerialNumber:
+ IPMIFruProperty: Serial Number
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruProperty: Name
+ IPMIFruSection: Board
+ xyz.openbmc_project.Inventory.Item.Tpm:
diff --git a/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-volatile-sensor-mrw.yaml b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-volatile-sensor-mrw.yaml
new file mode 100644
index 000000000..1fcf935f9
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-hostboot-volatile-sensor-mrw.yaml
@@ -0,0 +1,16 @@
+hb_volatile_sensor:
+ interfaces:
+ xyz.openbmc_project.Object.Enable:
+ Enabled:
+ Offsets:
+ 0:
+ assert: false
+ type: bool
+ 1:
+ assert: true
+ type: bool
+ mutability: Mutability::Write|Mutability::Read
+ path: /org/open_power/control/volatile
+ readingType: assertion
+ sensorNamePattern: nameLeaf
+ serviceInterface: org.freedesktop.DBus.Properties
diff --git a/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-occ-active-sensor-mrw.yaml b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-occ-active-sensor-mrw.yaml
new file mode 100644
index 000000000..5470c42da
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config/ipmi-occ-active-sensor-mrw.yaml
@@ -0,0 +1,17 @@
+occ_active_sensor:
+ interfaces:
+ org.open_power.OCC.Status:
+ OccActive:
+ Offsets:
+ 0:
+ assert: 'false'
+ deassert: 'true'
+ type: bool
+ 1:
+ assert: 'true'
+ deassert: 'false'
+ type: bool
+ mutability: Mutability::Write|Mutability::Read
+ readingType: assertion
+ sensorNamePattern: nameLeaf
+ serviceInterface: org.freedesktop.DBus.Properties
diff --git a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
index d8ae1cf98..84647bc38 100644
--- a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
+++ b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
@@ -39,7 +39,7 @@ S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
-SRCREV = "2b2d2298f5c6e9e596ed3ae84326a6ae804c46a4"
+SRCREV = "b8cb0cc9d9b3253df47bf019a8f028f01110f9ab"
DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.service b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.service
new file mode 100644
index 000000000..ce59b3377
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Init BMC Hostname
+Wants=mapper-wait@-xyz-openbmc_project-inventory.service
+After=mapper-wait@-xyz-openbmc_project-inventory.service
+
+[Service]
+ExecStart=/usr/bin/first-boot-set-hostname.sh
+Type=oneshot
+RemainAfterExit=Yes
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.sh b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.sh
new file mode 100644
index 000000000..541523760
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname/first-boot-set-hostname.sh
@@ -0,0 +1,46 @@
+#!/bin/sh -eu
+
+show_error() {
+ echo "$@" >&2
+}
+
+sync_hostname() {
+ MAPPER_IFACE='xyz.openbmc_project.ObjectMapper'
+ MAPPER_PATH='/xyz/openbmc_project/object_mapper'
+ INVENTORY_PATH='/xyz/openbmc_project/inventory'
+ BMC_ITEM_IFACE='xyz.openbmc_project.Inventory.Item.Bmc'
+
+ BMC_ITEM_PATH=$(busctl --no-pager --verbose call \
+ ${MAPPER_IFACE} \
+ ${MAPPER_PATH} \
+ ${MAPPER_IFACE} \
+ GetSubTree sias \
+ ${INVENTORY_PATH} 0 1 ${BMC_ITEM_IFACE} \
+ 2>/dev/null | grep ${INVENTORY_PATH} || true)
+
+ # ' STRING "/xyz/openbmc_project/inventory/system/chassis/bmc";'
+ BMC_ITEM_PATH=${BMC_ITEM_PATH#*\"}
+ BMC_ITEM_PATH=${BMC_ITEM_PATH%\"*}
+
+ BMC_ITEM_SERVICE=$(mapper get-service \
+ ${BMC_ITEM_PATH} 2>/dev/null || true)
+
+ if [[ -z "${BMC_ITEM_SERVICE}" ]]; then
+ echo "No BMC item found in the Inventory. Is VPD EEPROM empty?" >&2
+ return
+ fi
+
+ BMC_SN=$(busctl get-property ${BMC_ITEM_SERVICE} \
+ ${BMC_ITEM_PATH} \
+ ${BMC_ITEM_IFACE} SerialNumber)
+ # 's "002B0DH1000"'
+ BMC_SN=${BMC_SN#*\"}
+ BMC_SN=${BMC_SN%\"*}
+
+ hostnamectl set-hostname {MACHINE}-${BMC_SN}
+}
+
+[ "$(hostname)" = "{MACHINE}" ] && sync_hostname
+
+systemctl disable first-boot-set-hostname.service
+
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
new file mode 100644
index 000000000..1e9fdd66f
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Init BMC Hostname"
+DESCRIPTION = "Setup BMC Unique hostname"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch systemd
+
+RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
+
+SYSTEMD_SERVICE_${PN} = "first-boot-set-hostname.service"
+
+SRC_URI = "file://${PN}.sh file://${PN}.service"
+
+S = "${WORKDIR}"
+do_install() {
+ sed "s/{MACHINE}/${MACHINE}/" -i ${PN}.sh
+ install -d ${D}${bindir} ${D}${systemd_system_unitdir}
+ install ${PN}.sh ${D}${bindir}/
+ install -m 644 ${PN}.service ${D}${systemd_system_unitdir}/
+}
+