summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/conf/machine/include/p9.inc2
-rw-r--r--meta-openpower/recipes-bsp/ecmd/croserver_git.bb3
-rw-r--r--meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service1
-rw-r--r--meta-openpower/recipes-phosphor/host/op-host-control/vcs_workaround@.service19
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb25
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-host-start.bb3
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb20
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb1
-rw-r--r--meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc2
11 files changed, 33 insertions, 49 deletions
diff --git a/meta-openpower/conf/machine/include/p9.inc b/meta-openpower/conf/machine/include/p9.inc
index b0e0bb95e..4c30aac18 100644
--- a/meta-openpower/conf/machine/include/p9.inc
+++ b/meta-openpower/conf/machine/include/p9.inc
@@ -1,2 +1,2 @@
-OBMC_MACHINE_FEATURES += 'p9-vcs-workaround op-fsi p9-cfam-override'
+OBMC_MACHINE_FEATURES += 'op-fsi p9-cfam-override'
PREFERRED_PROVIDER_virtual/obmc-host-ctl = "p9-host-start"
diff --git a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
index 6dd7fae57..60b06ecb1 100644
--- a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
+++ b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
@@ -4,7 +4,7 @@ LICENSE= "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea"
SRC_URI = "git://github.com/open-power/eCMD.git"
-SRCREV = "b858b2f212bda2665ad41e821302e8196c7aec07"
+SRCREV = "79cadcd0d299cc044791da9b5e3746108290558a"
DEPENDS += "zlib"
SRC_URI += "file://croserver.service"
@@ -12,6 +12,7 @@ SRC_URI += "file://croserver.service"
S = "${WORKDIR}/git"
inherit python3native
+DEPENDS += "${PYTHON_PN}-distro-native"
do_configure() {
LD="${CXX}" ${PYTHON} ${S}/config.py \
diff --git a/meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service b/meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service
index 77a88e864..825275ae7 100644
--- a/meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service
+++ b/meta-openpower/recipes-phosphor/host/op-host-control/start_host@.service
@@ -8,6 +8,7 @@ Wants=obmc-power-on@%i.target
After=obmc-power-on@%i.target
Conflicts=obmc-host-stop@%i.target
ConditionPathExists=!/run/openbmc/host@%i-on
+ConditionPathExists=!/run/openbmc/mpreboot@%i
[Service]
ExecStart=/usr/bin/env openpower-proc-control startHost
diff --git a/meta-openpower/recipes-phosphor/host/op-host-control/vcs_workaround@.service b/meta-openpower/recipes-phosphor/host/op-host-control/vcs_workaround@.service
deleted file mode 100644
index bd9db809b..000000000
--- a/meta-openpower/recipes-phosphor/host/op-host-control/vcs_workaround@.service
+++ /dev/null
@@ -1,19 +0,0 @@
-[Unit]
-Description=Run VCS workaround on host%i
-Wants=obmc-host-start-pre@%i.target
-Before=obmc-host-start-pre@%i.target
-Wants=obmc-power-on@%i.target
-After=obmc-power-on@%i.target
-Wants=fsi-scan@%i.service
-After=fsi-scan@%i.service
-Conflicts=obmc-chassis-poweroff@%i.target
-ConditionPathExists=!/run/openbmc/chassis@%i-on
-
-[Service]
-ExecStart=/usr/bin/env openpower-proc-control vcsWorkaround
-SyslogIdentifier=openpower-proc-control
-Type=oneshot
-RemainAfterExit=yes
-
-[Install]
-WantedBy=obmc-chassis-poweron@%i.target
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 8185ddf8f..9cb75f33e 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -14,12 +14,19 @@ ALLOW_EMPTY_${PN} = "1"
pkg_postinst_${PN}() {
mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires
LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
TARGET="../op-stop-instructions@.service"
ln -s $TARGET $LINK
- LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
+ TARGET="../op-cfam-reset.service"
+ ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
TARGET="../op-cfam-reset.service"
ln -s $TARGET $LINK
@@ -30,16 +37,30 @@ pkg_postinst_${PN}() {
TARGET="../cfam_override@.service"
ln -s $TARGET $LINK
fi
+
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
+ TARGET="../op-continue-mpreboot@.service"
+ ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
+ TARGET="../op-enter-mpreboot@.service"
+ ln -s $TARGET $LINK
}
pkg_prerm_${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
rm $LINK
- LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
+ rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
rm $LINK
# Only uninstall cfam override if p9 system
if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
rm $LINK
fi
+ LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
+ rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
+ rm $LINK
}
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 01ef6b043..5fdbcaddb 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit autotools obmc-phosphor-utils pkgconfig
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "7847960506ca4357e267fe05866b38aad236708f"
+SRCREV = "c98bab51d0826daeb8cf5fe1725c0e8932cb1996"
DEPENDS += " \
autoconf-archive-native \
@@ -34,4 +34,6 @@ SYSTEMD_SERVICE_${PN} += " \
op-stop-instructions@.service \
op-cfam-reset.service \
${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'set-spi-mux.service', '', d)} \
+ op-continue-mpreboot@.service \
+ op-enter-mpreboot@.service \
"
diff --git a/meta-openpower/recipes-phosphor/host/p9-host-start.bb b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
index 6905f34aa..84dc7b14a 100644
--- a/meta-openpower/recipes-phosphor/host/p9-host-start.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
@@ -11,8 +11,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
PROVIDES += 'virtual/obmc-host-ctl'
RPROVIDES_${PN} += 'virtual-obmc-host-ctl'
-RDEPENDS_${PN} += "p9-vcs-workaround \
- op-proc-control \
+RDEPENDS_${PN} += "op-proc-control \
op-proc-control-systemd-links"
S = "${WORKDIR}"
diff --git a/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb b/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb
deleted file mode 100644
index 29167b0e1..000000000
--- a/meta-openpower/recipes-phosphor/host/p9-vcs-workaround.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SUMMARY = "POWER9 VCS workaround"
-DESCRIPTION = "Apply fixes over FSI to POWER9 CPUs prior to host power on"
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit obmc-phosphor-systemd
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
-RDEPENDS_${PN} += "virtual-p9-vcs-workaround op-proc-control"
-
-S = "${WORKDIR}"
-
-TMPL = "vcs_workaround@.service"
-INSTFMT = "vcs_workaround@{0}.service"
-TGTFMT = "obmc-chassis-poweron@{0}.target"
-FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
-
-SYSTEMD_SERVICE_${PN} += "${TMPL}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
index 142c09d8d..67350a3d7 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
@@ -19,7 +19,6 @@ DEPENDS += "${PYTHON_PN}-mako-native"
DEPENDS += "${PYTHON_PN}-pyyaml-native"
DEPENDS += "phosphor-logging"
DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
-DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
TARGET_CFLAGS += "-fpic"
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
index be11e2c43..673729b66 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
@@ -9,7 +9,7 @@ SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
SYSTEMD_SERVICE_${PN} = "attn_handler.service"
PV = "0.1+git${SRCPV}"
-SRCREV = "cf0e074e5793890920bc77075f207e21bef175fa"
+SRCREV = "72feadcff8f5ebcb3ad1ae2aa6877b512b106135"
S = "${WORKDIR}/git"
diff --git a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc
index f064d1270..668bef8a8 100644
--- a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc
+++ b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/openpower-vpd-parser"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/openpower-vpd-parser"
-SRCREV = "3d7b4fe107d210fb300ae8dccf07252ccda4c00c"
+SRCREV = "ee72ab53e95318f247d2f791a3d9eb10824d430b"