summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/conf/layer.conf2
-rw-r--r--meta-openpower/recipes-bsp/ecmd/croserver_git.bb6
-rw-r--r--meta-openpower/recipes-bsp/ecmd/libecmd_git.bb61
-rw-r--r--meta-openpower/recipes-bsp/pdbg/pdbg_2.5-rc1.bb (renamed from meta-openpower/recipes-bsp/pdbg/pdbg_2.4.bb)4
-rw-r--r--meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces_git.bb9
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb6
-rw-r--r--meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb6
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb1
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc2
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb10
-rw-r--r--meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb10
-rw-r--r--meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc2
-rw-r--r--meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb8
16 files changed, 100 insertions, 39 deletions
diff --git a/meta-openpower/conf/layer.conf b/meta-openpower/conf/layer.conf
index 0b3f1a8b6..134e5ef38 100644
--- a/meta-openpower/conf/layer.conf
+++ b/meta-openpower/conf/layer.conf
@@ -9,4 +9,4 @@ BBFILE_COLLECTIONS += "openpower-layer"
BBFILE_PATTERN_openpower-layer := "^${LAYERDIR}/"
LAYERVERSION_openpower-layer = "1"
LAYERDEPENDS_openpower-layer = "core phosphor-layer aspeed-layer"
-LAYERSERIES_COMPAT_openpower-layer = "warrior zeus"
+LAYERSERIES_COMPAT_openpower-layer = "warrior zeus dunfell"
diff --git a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
index 376392350..6dd7fae57 100644
--- a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
+++ b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
@@ -11,10 +11,12 @@ SRC_URI += "file://croserver.service"
S = "${WORKDIR}/git"
-inherit pythonnative
+inherit python3native
do_configure() {
- LD="${CXX}" ${S}/config.py --without-swig --output-root ${B} --target obj --extensions "cmd cip" --build-verbose
+ LD="${CXX}" ${PYTHON} ${S}/config.py \
+ --without-swig --output-root ${B} --target obj \
+ --extensions "cmd cip" --build-verbose
}
do_compile() {
diff --git a/meta-openpower/recipes-bsp/ecmd/libecmd_git.bb b/meta-openpower/recipes-bsp/ecmd/libecmd_git.bb
new file mode 100644
index 000000000..c2e43a4ce
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ecmd/libecmd_git.bb
@@ -0,0 +1,61 @@
+SUMMARY = "eCMD"
+DESCRIPTION = "eCMD is a hardware access API for POWER Systems"
+LICENSE= "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea"
+
+SRC_URI = "git://github.com/open-power/eCMD.git;branch=ecmd15;protocol=git"
+SRCREV = "15e382180d49f7ea4117ccc341ca91e361721fd4"
+
+inherit python3native
+DEPENDS = "zlib"
+
+S = "${WORKDIR}/git"
+
+export LD="${CXX}"
+export SLDFLAGS="${LDFLAGS}"
+
+# use native config.py to build required ecmd extensions
+do_configure() {
+ ${S}/config.py --without-swig --without-python --without-python3 --without-perl \
+ --without-pyecmd --install-path ${D}${prefix} --output-root ${B} --target ${TARGET_ARCH} \
+ --extensions "cmd cip"
+}
+
+do_compile() {
+ oe_runmake all
+}
+
+do_install() {
+ oe_runmake install
+
+ # we don't need the target scripts or ecmd setup
+ rm ${D}${bindir}/target.* ${D}${bindir}/ecmdsetup.pl
+
+ # ecmd installs to atypical places in the filesystem.
+ # move all the installed files to more conventional directories.
+ install -d ${D}${includedir} ${D}${datadir}/${BPN}/help ${D}${bindir} ${D}${libdir}
+ mv ${D}${prefix}/help/** ${D}${datadir}/${BPN}/help
+ mv ${D}${prefix}/${TARGET_ARCH}/bin/** ${D}${bindir}
+ mv ${D}${prefix}/${TARGET_ARCH}/lib/** ${D}${libdir}
+
+ rm ${D}${bindir}/ecmdVersion
+
+ rmdir ${D}${prefix}/help \
+ ${D}${prefix}/${TARGET_ARCH}/lib \
+ ${D}${prefix}/${TARGET_ARCH}/bin \
+ ${D}${prefix}/${TARGET_ARCH}/perl \
+ ${D}${prefix}/${TARGET_ARCH}
+}
+
+# ecmd makefile assumes that dependencies are built from left to right.
+PARALLEL_MAKE = ""
+
+# ecmd doesn't have proper library versioning
+FILES_${PN}-dev_remove = "${libdir}/lib*.so"
+FILES_${PN} += "${libdir}/lib*.so"
+
+RDEPENDS_${PN}-bin = "libecmd"
+
+# This allows someone to easily use ecmd bins, even if you don’t want them.
+PACKAGE_BEFORE_PN = "libecmd-bin"
+FILES_${PN}-bin += "${bindir}"
diff --git a/meta-openpower/recipes-bsp/pdbg/pdbg_2.4.bb b/meta-openpower/recipes-bsp/pdbg/pdbg_2.5-rc1.bb
index 08f936d18..42c65e680 100644
--- a/meta-openpower/recipes-bsp/pdbg/pdbg_2.4.bb
+++ b/meta-openpower/recipes-bsp/pdbg/pdbg_2.5-rc1.bb
@@ -3,10 +3,8 @@ DESCRIPTION = "pdbg allows JTAG-like debugging of the host POWER processors"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
-PV = "2.4+git${SRCPV}"
-
SRC_URI += "git://github.com/open-power/pdbg.git"
-SRCREV = "8b4611b5d8e7e2279fe4aa80c892fcfe10aa398d"
+SRCREV = "6ae2ba655ca5e24b403a33bf15dff7261d3e7052"
DEPENDS += "dtc-native"
diff --git a/meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces_git.bb b/meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces_git.bb
index 62eaf634c..3545018b3 100644
--- a/meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces_git.bb
+++ b/meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces_git.bb
@@ -8,25 +8,22 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
-inherit pythonnative
+inherit python3native
inherit phosphor-dbus-yaml
DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbus++-native"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
DEPENDS += "phosphor-dbus-interfaces"
SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces"
SRCREV = "109ded04f3fec7bbbd93f9c9956a355f4894a51f"
-DEPENDS_remove_class-native = "sdbus++-native"
-DEPENDS_remove_class-nativesdk = "sdbus++-native"
-
PACKAGECONFIG ??= "libopenpower_dbus"
PACKAGECONFIG[libopenpower_dbus] = " \
--enable-libopenpower_dbus, \
--disable-libopenpower_dbus, \
systemd sdbusplus, \
- libsystemd sdbusplus \
+ libsystemd \
"
PACKAGECONFIG_remove_class-native = "libopenpower_dbus"
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
index d79a01c5e..08b58ea7c 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
@@ -7,15 +7,15 @@ PV = "1.0+git${SRCPV}"
inherit autotools \
pkgconfig \
obmc-phosphor-systemd \
- pythonnative \
+ python3native \
phosphor-dbus-yaml
-require ${PN}.inc
+require ${BPN}.inc
DEPENDS += " \
phosphor-logging \
autoconf-archive-native \
- sdbus++-native \
+ ${PYTHON_PN}-sdbus++-native \
"
S = "${WORKDIR}/git"
diff --git a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
index 9c71a1e7c..841373706 100644
--- a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
+++ b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
@@ -10,7 +10,6 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit autotools pkgconfig systemd
inherit obmc-phosphor-dbus-service
-inherit pythonnative
inherit ${@bb.utils.contains('DISTRO_FEATURES', 'openpower-ubi-fs', \
'openpower-software-manager-ubi', \
@@ -33,7 +32,6 @@ DEPENDS += " \
phosphor-dbus-interfaces \
phosphor-logging \
sdbusplus \
- sdbusplus-native \
"
RDEPENDS_${PN} += " \
@@ -44,7 +42,7 @@ S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
-SRCREV = "7f1967d56b89ffae5ea8e3313c000beb79cb63cd"
+SRCREV = "228f16d47bf2fd45022faf05647e2bb1981a56f7"
DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index b8105fc8d..8185ddf8f 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -12,10 +12,10 @@ RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
ALLOW_EMPTY_${PN} = "1"
pkg_postinst_${PN}() {
- mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
- LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
+ LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
TARGET="../op-stop-instructions@.service"
ln -s $TARGET $LINK
@@ -33,7 +33,7 @@ pkg_postinst_${PN}() {
}
pkg_prerm_${PN}() {
- LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
+ LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
rm $LINK
LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
rm $LINK
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 9f17aa243..01ef6b043 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -33,4 +33,5 @@ SYSTEMD_SERVICE_${PN} += " \
xyz.openbmc_project.Control.Host.NMI.service \
op-stop-instructions@.service \
op-cfam-reset.service \
+ ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'set-spi-mux.service', '', d)} \
"
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
index 0b1e52b48..f0d54ea54 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
@@ -10,7 +10,7 @@ inherit obmc-phosphor-ipmiprovider-symlink
DEPENDS += "phosphor-ipmi-host"
DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "sdbusplus"
DEPENDS += "phosphor-logging"
DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
@@ -22,7 +22,7 @@ HOSTIPMI_PROVIDER_LIBRARY += "libhiomap.so"
S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-flash"
-SRCREV = "d4b7f5e4819aa6e3ddb165a80149dd1a1c1649d7"
+SRCREV = "a182dce8b97c4ca17832b4cc47c7a7b947291466"
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc
index 81a901c74..7cfe609f4 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
-SRCREV = "36ae8e5c4256b751ada4d6a2c9486c78d03ecba9"
+SRCREV = "9975ae919e4cb8968639d9f953912e6c73205c44"
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
index 711b7e6a3..142c09d8d 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
@@ -7,17 +7,19 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
inherit autotools pkgconfig
inherit obmc-phosphor-ipmiprovider-symlink
-inherit pythonnative
+inherit python3native
-require ${PN}.inc
+require ${BPN}.inc
DEPENDS += "phosphor-ipmi-host"
DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "sdbusplus"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
+DEPENDS += "${PYTHON_PN}-mako-native"
+DEPENDS += "${PYTHON_PN}-pyyaml-native"
DEPENDS += "phosphor-logging"
DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
-DEPENDS += "sdbus++-native"
DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
TARGET_CFLAGS += "-fpic"
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
index 78ad53572..be11e2c43 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
@@ -5,11 +5,11 @@ DESCRIPTION = "Attention Handler and Hardware Diagnostics"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-SRC_URI = "git://github.com/projects/openbmc/openpower-hw-diags"
+SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
SYSTEMD_SERVICE_${PN} = "attn_handler.service"
PV = "0.1+git${SRCPV}"
-SRCREV = "73ac368a7e435b27d1100037eb76ee65f6a85ce6"
+SRCREV = "cf0e074e5793890920bc77075f207e21bef175fa"
S = "${WORKDIR}/git"
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index aaab247f7..210b5fcc2 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -10,7 +10,7 @@ inherit autotools \
python3native \
phosphor-dbus-yaml
-require ${PN}.inc
+require ${BPN}.inc
SRC_URI += "file://occ-active.sh"
do_install_append() {
@@ -26,7 +26,7 @@ SYSTEMD_SERVICE_${PN} += "op-occ-disable@.service"
DEPENDS += "virtual/${PN}-config-native"
DEPENDS += " \
sdbusplus \
- sdbusplus-native \
+ ${PYTHON_PN}-sdbus++-native \
phosphor-logging \
phosphor-dbus-interfaces \
autoconf-archive-native \
@@ -50,11 +50,11 @@ OCC_DISABLE = "disable"
HOST_START = "startmin"
HOST_STOP = "stop"
-# Ensure host-stop and host-startmin targets require needed occ states
+# Ensure host-stop and host-startmin targets wants needed occ states
OCC_TMPL = "op-occ-{0}@.service"
HOST_TGTFMT = "obmc-host-{1}@{2}.target"
OCC_INSTFMT = "op-occ-{0}@{2}.service"
-HOST_OCC_FMT = "../${OCC_TMPL}:${HOST_TGTFMT}.requires/${OCC_INSTFMT}"
+HOST_OCC_FMT = "../${OCC_TMPL}:${HOST_TGTFMT}.wants/${OCC_INSTFMT}"
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_ENABLE', 'HOST_START', 'OBMC_HOST_INSTANCES')}"
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_DISABLE', 'HOST_STOP', 'OBMC_HOST_INSTANCES')}"
@@ -74,6 +74,7 @@ S = "${WORKDIR}/git"
DEPENDS_remove_class-native = " \
phosphor-logging \
systemd \
+ sdbusplus \
virtual/${PN}-config-native \
"
RDEPENDS_${PN}_remove_class-native += "phosphor-state-manager-obmc-targets"
@@ -82,6 +83,7 @@ RDEPENDS_${PN}_remove_class-native += "phosphor-state-manager-obmc-targets"
DEPENDS_remove_class-nativesdk = " \
phosphor-logging \
systemd \
+ sdbusplus \
virtual/${PN}-config-native \
"
RDEPENDS_${PN}_remove_class-nativesdk += "phosphor-state-manager-obmc-targets"
diff --git a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc
index a65c9162e..f064d1270 100644
--- a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc
+++ b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/openpower-vpd-parser"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/openpower-vpd-parser"
-SRCREV = "675ee7e4459c8c3fc5c2733289dc35406bb6d400"
+SRCREV = "3d7b4fe107d210fb300ae8dccf07252ccda4c00c"
diff --git a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
index 87377edc5..b82ae84da 100644
--- a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
+++ b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
@@ -5,10 +5,10 @@ PV = "1.0+git${SRCPV}"
inherit autotools pkgconfig
inherit openpower-fru-vpd
-inherit pythonnative
+inherit python3native
inherit obmc-phosphor-systemd
-require ${PN}.inc
+require ${BPN}.inc
SRC_URI += "file://70-op-vpd.rules"
@@ -18,8 +18,8 @@ DEPENDS += " \
virtual/openpower-fru-properties \
sdbusplus \
phosphor-logging \
- python-mako-native \
- python-pyyaml-native \
+ ${PYTHON_PN}-mako-native \
+ ${PYTHON_PN}-pyyaml-native \
autoconf-archive-native \
"