summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-bsp/ecmd/croserver_git.bb2
-rw-r--r--meta-openpower/recipes-bsp/ekb/ekb.inc23
-rw-r--r--meta-openpower/recipes-bsp/ekb/ekb_git.bb25
-rw-r--r--meta-openpower/recipes-bsp/guard/guard_git.bb19
-rw-r--r--meta-openpower/recipes-bsp/ipl/ipl_git.bb23
-rw-r--r--meta-openpower/recipes-bsp/libekb/libekb_git.bb27
-rwxr-xr-xmeta-openpower/recipes-bsp/pdata/files/power-target.sh6
-rw-r--r--meta-openpower/recipes-bsp/pdata/pdata_git.bb27
-rw-r--r--meta-openpower/recipes-bsp/pdata/phal-devtree.bb22
-rw-r--r--meta-openpower/recipes-bsp/pdbg/pdbg_3.3.bb (renamed from meta-openpower/recipes-bsp/pdbg/pdbg_3.2.bb)2
-rw-r--r--meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb3
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb7
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc2
-rw-r--r--meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb13
-rw-r--r--meta-openpower/recipes-phosphor/logging/openpower-libhei-rev.inc6
-rw-r--r--meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb19
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control.inc2
-rw-r--r--meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc2
18 files changed, 208 insertions, 22 deletions
diff --git a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
index 3d9209bfb..e1aa88e51 100644
--- a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
+++ b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
@@ -4,7 +4,7 @@ LICENSE= "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea"
SRC_URI = "git://github.com/open-power/eCMD.git"
-SRCREV = "d35b5c025a3f629401ea1352f6e53aa7429950ca"
+SRCREV = "57b40102a54dac8b4b9cdc91beefd709d222867e"
DEPENDS += "zlib"
SRC_URI += "file://croserver.service"
diff --git a/meta-openpower/recipes-bsp/ekb/ekb.inc b/meta-openpower/recipes-bsp/ekb/ekb.inc
new file mode 100644
index 000000000..268a55dd5
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ekb/ekb.inc
@@ -0,0 +1,23 @@
+EKB_BRANCH = "main-p10"
+EKB_URI = "git://git@github.com/open-power/pub-ekb;branch=${EKB_BRANCH}"
+EKB_REV = "52e5c0038a50cc641dffdc6158f8c21930c70678"
+
+REQ_ATTRS_XMLS = "hwpf/fapi2/xml/attribute_info/chip_attributes.xml \
+ hwpf/fapi2/xml/attribute_info/common_attributes.xml \
+ hwpf/fapi2/xml/attribute_info/scratch_attributes.xml \
+ hwpf/fapi2/xml/attribute_info/system_attributes.xml \
+ hwpf/fapi2/xml/attribute_info/unit_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_bars_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_chip_ec_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_clock_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_freq_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_hcode_image_build_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_ipl_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_ipl_customize_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_memory_bars_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_nest_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_pervasive_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_qme_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_runn_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_sbe_load_bootloader_attributes.xml \
+ chips/p10/procedures/xml/attribute_info/p10_sbe_attributes.xml"
diff --git a/meta-openpower/recipes-bsp/ekb/ekb_git.bb b/meta-openpower/recipes-bsp/ekb/ekb_git.bb
new file mode 100644
index 000000000..4ecf1f8d3
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ekb/ekb_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "To get required hardware procedure attribute xml files"
+DESCRIPTION = "Copy all the required hardware procedures attributes xml file \
+with respective directory structures"
+
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE_PROLOG;md5=d8e5f403c98fd80dcea90b9cc8cd083c"
+
+require ekb.inc
+
+SRC_URI = "${EKB_URI}"
+SRCREV = "${EKB_REV}"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"
+
+do_install() {
+
+ mkdir -p ${D}${datadir}/${BPN}
+
+ # Copying all required hwp's attributes xml file with respective directory structures
+ (cd ${S} && cp --parents ${REQ_ATTRS_XMLS} ${D}${datadir}/${BPN})
+}
diff --git a/meta-openpower/recipes-bsp/guard/guard_git.bb b/meta-openpower/recipes-bsp/guard/guard_git.bb
new file mode 100644
index 000000000..0d5ff964f
--- /dev/null
+++ b/meta-openpower/recipes-bsp/guard/guard_git.bb
@@ -0,0 +1,19 @@
+HOMEPAGE = "https://github.com/open-power/guard"
+SUMMARY = "Guard the faulty components"
+DESCRIPTION = "Provide a way to guard the faulty component from the system"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit meson
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://git@github.com/open-power/guard;branch="main""
+SRCREV = "87b02b63b64b36a925bec42723d70e0531e93407"
+
+DEPENDS = "cli11"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}"
+PACKAGECONFIG[phal] = "-Ddevtree=enabled, -Ddevtree=disabled, pdata pdbg"
diff --git a/meta-openpower/recipes-bsp/ipl/ipl_git.bb b/meta-openpower/recipes-bsp/ipl/ipl_git.bb
new file mode 100644
index 000000000..edd44bc78
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ipl/ipl_git.bb
@@ -0,0 +1,23 @@
+HOMEPAGE = "https://github.com/open-power/ipl/"
+
+SUMMARY = "Initial Program Load steps"
+DESCRIPTION = "Provides infrastructure to run istep"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+inherit autotools
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://git@github.com/open-power/ipl;branch="main""
+SRCREV = "65b394476c6ec40192b6cc44c6722cee5a5bee20"
+
+DEPENDS = " \
+ libekb pdbg autoconf-archive guard \
+ "
+
+RDEPENDS_${PN} = "phal-devtree"
+
+EXTRA_OECONF = "CHIP=p10"
diff --git a/meta-openpower/recipes-bsp/libekb/libekb_git.bb b/meta-openpower/recipes-bsp/libekb/libekb_git.bb
new file mode 100644
index 000000000..ac650a4a8
--- /dev/null
+++ b/meta-openpower/recipes-bsp/libekb/libekb_git.bb
@@ -0,0 +1,27 @@
+HOMEPAGE = "https://github.com/open-power/libekb_p10"
+
+SUMMARY = "Hardware Procedure Framework"
+DESCRIPTION = "Provides infrastructure to run hardware procedures"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+S = "${WORKDIR}/git"
+
+require recipes-bsp/ekb/ekb.inc
+
+inherit autotools \
+ python3native \
+ perlnative
+
+SRCREV_FORMAT = "libekb_ekb"
+
+SRCREV_libekb = "a68c2f610243d3f128f561c4451135241aedbf6b"
+SRCREV_ekb = "${EKB_REV}"
+
+SRC_URI = "git://git@github.com/open-power/libekb_p10;branch="main";name=libekb \
+ ${EKB_URI};name=ekb;destsuffix=git/ekb \
+ "
+
+DEPENDS = "pdbg libxml-simple-perl-native"
diff --git a/meta-openpower/recipes-bsp/pdata/files/power-target.sh b/meta-openpower/recipes-bsp/pdata/files/power-target.sh
new file mode 100755
index 000000000..10c985050
--- /dev/null
+++ b/meta-openpower/recipes-bsp/pdata/files/power-target.sh
@@ -0,0 +1,6 @@
+# Command line debug tools like pdbg and ecmd requires
+# PDBG_DTB environment variable.
+# attributes tool required both PDBG_DTB and PDATA_INFODB.
+
+export PDBG_DTB=/var/lib/phosphor-software-manager/pnor/rw/DEVTREE
+export PDATA_INFODB=/usr/share/pdata/attributes_info.db
diff --git a/meta-openpower/recipes-bsp/pdata/pdata_git.bb b/meta-openpower/recipes-bsp/pdata/pdata_git.bb
new file mode 100644
index 000000000..50f406db1
--- /dev/null
+++ b/meta-openpower/recipes-bsp/pdata/pdata_git.bb
@@ -0,0 +1,27 @@
+HOMEPAGE = "https://github.com/open-power/pdata/"
+
+SUMMARY = "POWER Host data management"
+DESCRIPTION = "Devicetree based POWER host data management"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+S = "${WORKDIR}/git"
+
+inherit autotools \
+ perlnative
+
+SRC_URI = "git://git@github.com/open-power/pdata;branch="main""
+SRCREV = "a617306c59c81b879aeb1a3d271b5f633895efd0"
+
+DEPENDS = "pdbg \
+ libxml-simple-perl-native \
+ libxml-libxml-perl-native \
+ ekb-native \
+ autoconf-archive"
+
+PDATA_CONFARG = "CHIP=p10"
+EXTRA_OECONF = "--enable-gen_attrsinfo ${PDATA_CONFARG}"
+
+EXTRA_OEMAKE = "EKB=${STAGING_DATADIR_NATIVE}/ekb/"
diff --git a/meta-openpower/recipes-bsp/pdata/phal-devtree.bb b/meta-openpower/recipes-bsp/pdata/phal-devtree.bb
new file mode 100644
index 000000000..4ad477ae4
--- /dev/null
+++ b/meta-openpower/recipes-bsp/pdata/phal-devtree.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Tools and libraries to manage the phal devicetree"
+DESCRIPTION = "phal(power hardware abstraction layer) devicetree data \
+modelling mainly includes the host hardware topology and attributes, \
+which includes the configuration data"
+
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+PDATA_DTB_PATH="${datadir}/pdata"
+FILES_${PN} += "${PDATA_DTB_PATH}"
+
+do_install() {
+
+ DTB_FILE_ENV=power-target.sh
+ DTB_FILE_CONF_PATH=${D}${PDATA_DTB_PATH}
+
+ install -d ${DTB_FILE_CONF_PATH}
+ install -m 744 ${THISDIR}/files/${DTB_FILE_ENV} ${DTB_FILE_CONF_PATH}/${DTB_FILE_ENV}
+ install -d ${D}${sysconfdir}/profile.d
+ ln -s ${PDATA_DTB_PATH}/${DTB_FILE_ENV} ${D}${sysconfdir}/profile.d/${DTB_FILE_ENV}
+}
diff --git a/meta-openpower/recipes-bsp/pdbg/pdbg_3.2.bb b/meta-openpower/recipes-bsp/pdbg/pdbg_3.3.bb
index 175bad4bd..d7b3c31b9 100644
--- a/meta-openpower/recipes-bsp/pdbg/pdbg_3.2.bb
+++ b/meta-openpower/recipes-bsp/pdbg/pdbg_3.3.bb
@@ -4,7 +4,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI += "git://github.com/open-power/pdbg.git"
-SRCREV = "v3.2"
+SRCREV = "v3.3"
DEPENDS += "dtc-native"
diff --git a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
index 86005732b..8cd50970c 100644
--- a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
+++ b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
@@ -37,6 +37,7 @@ PACKAGECONFIG[mmc_layout] = "-Ddevice-type=mmc"
PACKAGECONFIG[virtual_pnor] = "-Dvpnor=enabled, -Dvpnor=disabled"
EXTRA_OEMESON += " \
+ -Dtests=disabled \
-Dmsl="v2.0.10 v2.2" \
"
@@ -59,7 +60,7 @@ S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
-SRCREV = "067876aa2af9629161c4f367750828aec5e0cd63"
+SRCREV = "fdc91fa011c28b857220e30320fba65e69907f20"
DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 12ebbea49..546031bbf 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -7,19 +7,20 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
S = "${WORKDIR}/git"
-inherit autotools obmc-phosphor-utils pkgconfig
+inherit meson obmc-phosphor-utils pkgconfig
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "1b607c35462ae5e2c00406a646aeedbbd26d4631"
+SRCREV = "f8c14bcfd507e0224fe258d38bdef8d32ebfbf48"
DEPENDS += " \
- autoconf-archive-native \
phosphor-logging \
phosphor-dbus-interfaces \
libgpiod \
"
+EXTRA_OEMESON += "-Dtests=disabled"
+
# For libpdbg, provided by the pdbg package
DEPENDS += "pdbg"
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc
index 1210b55db..b9ec99ec8 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
-SRCREV = "248255d2afd411ca05e2596fcb214b8968a08743"
+SRCREV = "98af91d62e307a360f1f89df6a275baa88aa05f4"
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
index 6202c3621..3c3c5325e 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
@@ -1,4 +1,3 @@
-HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags"
SUMMARY = "Hardware Diagnostics for POWER Systems"
DESCRIPTION = \
@@ -7,16 +6,20 @@ DESCRIPTION = \
POWER Systems have the ability to diagnose the root cause of the failure \
and perform any service action needed to avoid repeated system failures."
-PV = "0.1+git${SRCPV}"
+HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags"
+
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-inherit meson systemd
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+
+SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
+SRCREV = "324234b4b560ce1d136d96a6950daeb1da1469a5"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
-SRCREV = "5c5db65a37d953cb9393f257aab90a0a209d4861"
+inherit meson systemd
SYSTEMD_SERVICE_${PN} = "attn_handler.service"
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-libhei-rev.inc b/meta-openpower/recipes-phosphor/logging/openpower-libhei-rev.inc
new file mode 100644
index 000000000..715c04964
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/logging/openpower-libhei-rev.inc
@@ -0,0 +1,6 @@
+PR = "r1"
+PV = "0.1+git${SRCPV}"
+
+SRC_URI = "git://github.com/openbmc/openpower-libhei"
+SRCREV = "47ca5c2e7a172e39d104551ff2ed8db4eea51217"
+
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb
index 59ed91c25..183e2ed5c 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-libhei_git.bb
@@ -1,17 +1,20 @@
-inherit meson
+SUMMARY = "Hardware Error Isolator for POWER Systems"
+
+DESCRIPTION = \
+ "The library provides a set of tools to isolate hardware attentions driven \
+ by POWER Systems chip (processor chips, memory chips, etc.)."
+
+HOMEPAGE = "https://github.com/openbmc/openpower-libhei"
-SUMMARY = "Hardware Error Isolator Library"
-DESCRIPTION = "Hardware Error Isolator Library (libhei)"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-SRC_URI = "git://github.com/openbmc/openpower-libhei"
-
-PV = "0.1+git${SRCPV}"
-SRCREV = "0a905012d0e90ea32ca651883413cd84b56804d1"
+include openpower-libhei-rev.inc
S = "${WORKDIR}/git"
+inherit meson
inherit perlnative
-DEPENDS += "libxml2-native libxml-simple-perl-native libjson-perl-native"
+DEPENDS = "libxml2-native libxml-simple-perl-native libjson-perl-native"
+
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control.inc b/meta-openpower/recipes-phosphor/occ/openpower-occ-control.inc
index cd31b488c..77257cf90 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control.inc
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/openpower-occ-control"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/openpower-occ-control"
-SRCREV = "4c1079e71ae3ecbce8a9ddc33ee4e7d623d66568"
+SRCREV = "eeb95bade422e598aba91c9cbbb870bba38d5ae3"
diff --git a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc
index 0d0d53ba7..d8499cffe 100644
--- a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc
+++ b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/openpower-vpd-parser"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/openpower-vpd-parser"
-SRCREV = "33c61c2d634c116d9b31b0a3d7c69860e9dbcaab"
+SRCREV = "b0f3749d793ff1e11310ca5b729274afbbd85241"