summaryrefslogtreecommitdiff
path: root/meta-phosphor/classes
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/classes')
-rw-r--r--meta-phosphor/classes/config-in-skeleton.bbclass36
-rw-r--r--meta-phosphor/classes/image_types_phosphor.bbclass13
-rw-r--r--meta-phosphor/classes/mrw-rev.bbclass2
-rw-r--r--meta-phosphor/classes/obmc-phosphor-image.bbclass2
-rw-r--r--meta-phosphor/classes/obmc-phosphor-python-autotools.bbclass30
-rw-r--r--meta-phosphor/classes/obmc-phosphor-systemd.bbclass6
-rw-r--r--meta-phosphor/classes/phosphor-networkd-rev.bbclass2
7 files changed, 21 insertions, 70 deletions
diff --git a/meta-phosphor/classes/config-in-skeleton.bbclass b/meta-phosphor/classes/config-in-skeleton.bbclass
deleted file mode 100644
index b76753724..000000000
--- a/meta-phosphor/classes/config-in-skeleton.bbclass
+++ /dev/null
@@ -1,36 +0,0 @@
-# In general this class should only be used by board layers
-# that keep their machine-readable-workbook in the skeleton repository.
-
-inherit allarch
-inherit setuptools
-inherit pythonnative
-inherit skeleton-rev
-
-HOMEPAGE = "http://github.com/openbmc/skeleton"
-
-PROVIDES += "virtual/obmc-inventory-data"
-RPROVIDES_${PN} += "virtual-obmc-inventory-data"
-
-DEPENDS += "python"
-SRC_URI += "${SKELETON_URI};"
-S = "${WORKDIR}/git/configs"
-
-python() {
- machine = d.getVar('MACHINE', True).capitalize() + '.py'
- d.setVar('_config_in_skeleton', machine)
-}
-
-do_make_setup() {
- cp ${S}/${_config_in_skeleton} \
- ${S}/obmc_system_config.py
- cat <<EOF > ${S}/setup.py
-from distutils.core import setup
-
-setup(name='${BPN}',
- version='${PR}',
- py_modules=['obmc_system_config'],
- )
-EOF
-}
-
-addtask make_setup after do_patch before do_configure
diff --git a/meta-phosphor/classes/image_types_phosphor.bbclass b/meta-phosphor/classes/image_types_phosphor.bbclass
index 39534db8d..0259cf634 100644
--- a/meta-phosphor/classes/image_types_phosphor.bbclass
+++ b/meta-phosphor/classes/image_types_phosphor.bbclass
@@ -42,6 +42,7 @@ FLASH_PAGE_SIZE ?= "1"
FLASH_NOR_UBI_OVERHEAD ?= "64"
# Fixed partition offsets
+FLASH_UBOOT_SPL_SIZE ?= "64"
FLASH_UBOOT_OFFSET ?= "0"
FLASH_KERNEL_OFFSET ?= "512"
FLASH_KERNEL_OFFSET_flash-131072 ?= "1024"
@@ -336,9 +337,19 @@ python do_generate_static() {
'if=%s' % imgpath,
'of=%s' % nor_image])
+ uboot_offset = int(d.getVar('FLASH_UBOOT_OFFSET', True))
+
+ spl_binary = d.getVar('SPL_BINARY', True)
+ if spl_binary:
+ _append_image(os.path.join(d.getVar('DEPLOY_DIR_IMAGE', True),
+ 'u-boot-spl.%s' % d.getVar('UBOOT_SUFFIX',True)),
+ int(d.getVar('FLASH_UBOOT_OFFSET', True)),
+ int(d.getVar('FLASH_UBOOT_SPL_SIZE', True)))
+ uboot_offset += int(d.getVar('FLASH_UBOOT_SPL_SIZE', True))
+
_append_image(os.path.join(d.getVar('DEPLOY_DIR_IMAGE', True),
'u-boot.%s' % d.getVar('UBOOT_SUFFIX',True)),
- int(d.getVar('FLASH_UBOOT_OFFSET', True)),
+ uboot_offset,
int(d.getVar('FLASH_KERNEL_OFFSET', True)))
_append_image(os.path.join(d.getVar('DEPLOY_DIR_IMAGE', True),
diff --git a/meta-phosphor/classes/mrw-rev.bbclass b/meta-phosphor/classes/mrw-rev.bbclass
index b0a6b1f40..29384304c 100644
--- a/meta-phosphor/classes/mrw-rev.bbclass
+++ b/meta-phosphor/classes/mrw-rev.bbclass
@@ -2,4 +2,4 @@ MRW_API_SRC_URI ?= "git://github.com/open-power/serverwiz.git"
MRW_API_SRCREV ?= "60c8e10cbb11768cd1ba394b35cb1d6627efec42"
MRW_TOOLS_SRC_URI ?= "git://github.com/openbmc/phosphor-mrw-tools"
-MRW_TOOLS_SRCREV ?= "715c97ea76bb6c976e57dfa899f76a7106a7c2d5"
+MRW_TOOLS_SRCREV ?= "721dcbd23da4f9679ddf58119c478922bf420a1e"
diff --git a/meta-phosphor/classes/obmc-phosphor-image.bbclass b/meta-phosphor/classes/obmc-phosphor-image.bbclass
index 8ce0acd52..6e13a6520 100644
--- a/meta-phosphor/classes/obmc-phosphor-image.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-image.bbclass
@@ -38,7 +38,7 @@ FEATURE_PACKAGES_obmc-host-ipmi ?= "${@cf_enabled(d, 'obmc-host-ipmi', 'virtual-
FEATURE_PACKAGES_obmc-host-state-mgmt ?= "packagegroup-obmc-apps-host-state-mgmt"
FEATURE_PACKAGES_obmc-inventory ?= "packagegroup-obmc-apps-inventory"
FEATURE_PACKAGES_obmc-leds ?= "packagegroup-obmc-apps-leds"
-FEATURE_PACKAGES_obmc-logging-mgmt ?= "${@df_enabled(d, 'obmc-logging-mgmt', 'packagegroup-obmc-apps-logging')}"
+FEATURE_PACKAGES_obmc-logging-mgmt ?= "packagegroup-obmc-apps-logging"
FEATURE_PACKAGES_obmc-remote-logging-mgmt ?= "packagegroup-obmc-apps-remote-logging"
FEATURE_PACKAGES_obmc-net-ipmi ?= "phosphor-ipmi-net"
FEATURE_PACKAGES_obmc-sensors ?= "packagegroup-obmc-apps-sensors"
diff --git a/meta-phosphor/classes/obmc-phosphor-python-autotools.bbclass b/meta-phosphor/classes/obmc-phosphor-python-autotools.bbclass
deleted file mode 100644
index 0922a1ab6..000000000
--- a/meta-phosphor/classes/obmc-phosphor-python-autotools.bbclass
+++ /dev/null
@@ -1,30 +0,0 @@
-inherit obmc-phosphor-utils
-inherit pythonnative
-
-DEPENDS += "python"
-
-export BUILD_SYS
-export HOST_SYS
-export STAGING_INCDIR
-export STAGING_LIBDIR
-
-PYTHON_AUTOTOOLS_PACKAGE ?= "${PN}"
-
-python() {
- for pkg in listvar_to_list(d, 'PYTHON_AUTOTOOLS_PACKAGE'):
- set_append(d, 'FILES_%s' % pkg,
- d.getVar('PYTHON_SITEPACKAGES_DIR', True))
-}
-
-# In order to facilitate packages that use python3native, but also
-# depend on python2 scripts we need to replace the #! to be nativepython
-# instead of just python. Without this, `which python` points to the
-# host's python, which is not the one where required modules would be
-# installed.
-do_install_append_class-native() {
- for i in ${D}${bindir}/* ${D}${sbindir}/*; do
- if [ -f "$i" ]; then
- sed -i -e s:env\ python:env\ nativepython:g $i
- fi
- done
-}
diff --git a/meta-phosphor/classes/obmc-phosphor-systemd.bbclass b/meta-phosphor/classes/obmc-phosphor-systemd.bbclass
index 9b4419bcd..830d0390c 100644
--- a/meta-phosphor/classes/obmc-phosphor-systemd.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-systemd.bbclass
@@ -130,8 +130,11 @@ python() {
'base_bindir',
'bindir',
'sbindir',
+ 'libexecdir',
'envfiledir',
'sysconfdir',
+ 'localstatedir',
+ 'datadir',
'SYSTEMD_DEFAULT_TARGET' ]:
set_append(d, 'SYSTEMD_SUBSTITUTIONS',
'%s:%s:%s' % (x, d.getVar(x, True), file))
@@ -336,6 +339,9 @@ do_install_append() {
sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
-e 's,@BINDIR@,${bindir},g' \
-e 's,@SBINDIR@,${sbindir},g' \
+ -e 's,@LIBEXECDIR@,${libexecdir},g' \
+ -e 's,@LOCALSTATEDIR@,${localstatedir},g' \
+ -e 's,@DATADIR@,${datadir},g' \
${D}${systemd_system_unitdir}/$s
done
}
diff --git a/meta-phosphor/classes/phosphor-networkd-rev.bbclass b/meta-phosphor/classes/phosphor-networkd-rev.bbclass
index aa5dc3136..ed47935d0 100644
--- a/meta-phosphor/classes/phosphor-networkd-rev.bbclass
+++ b/meta-phosphor/classes/phosphor-networkd-rev.bbclass
@@ -1,2 +1,2 @@
SRC_URI += "git://github.com/openbmc/phosphor-networkd"
-SRCREV = "99801cea8c6dd13b4f4965c362966e5d497ea71e"
+SRCREV = "d0679f9bb46670c593061c4aaebec2a577cdd5c3"