summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb')
-rw-r--r--meta-phosphor/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb
new file mode 100644
index 000000000..5ce5818c5
--- /dev/null
+++ b/meta-phosphor/common/recipes-phosphor/obmc-phosphor-event/obmc-phosphor-event.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Phosphor OpenBMC Event Management"
+DESCRIPTION = "Phosphor OpenBMC event management reference implementation."
+HOMEPAGE = "https://github.com/openbmc/phosphor-event"
+PR = "r1"
+
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-event-mgmt
+inherit obmc-phosphor-sdbus-service
+inherit obmc-phosphor-c-daemon
+
+TARGET_CPPFLAGS += "-std=c++11 -fpic"
+
+SRC_URI += "git://github.com/openbmc/phosphor-event"
+
+SRCREV = "127c8cf513ba9ed6bcc460fbea29b36eb8d23bac"
+
+RDEPENDS_${PN} += "libsystemd"
+DEPENDS += "systemd"
+
+
+S = "${WORKDIR}/git"
+INSTALL_NAME = "event_messaged"
+
+do_install() {
+ install -d ${D}/var/lib/obmc/events/
+ install -m 0755 -d ${D}${sbindir}
+ install -m 0755 ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-eventd
+}