summaryrefslogtreecommitdiff
path: root/meta-phosphor/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/conf')
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-base.inc14
-rw-r--r--meta-phosphor/conf/distro/include/phosphor-mmc.inc2
-rw-r--r--meta-phosphor/conf/layer.conf2
-rw-r--r--meta-phosphor/conf/machine/include/ibm-power-cpu.inc1
-rw-r--r--meta-phosphor/conf/machine/include/ibm-power10-cpu.inc2
-rw-r--r--meta-phosphor/conf/machine/include/ibm-power8-cpu.inc2
-rw-r--r--meta-phosphor/conf/machine/include/ibm-power9-cpu.inc2
-rw-r--r--meta-phosphor/conf/machine/include/obmc-bsp-common.inc15
8 files changed, 32 insertions, 8 deletions
diff --git a/meta-phosphor/conf/distro/include/phosphor-base.inc b/meta-phosphor/conf/distro/include/phosphor-base.inc
index 8d53c8dda..93b24550c 100644
--- a/meta-phosphor/conf/distro/include/phosphor-base.inc
+++ b/meta-phosphor/conf/distro/include/phosphor-base.inc
@@ -8,6 +8,8 @@ POKY_DEFAULT_EXTRA_RRECOMMENDS = "kernel-module-af-packet"
DISTRO_EXTRA_RDEPENDS += " ${POKY_DEFAULT_EXTRA_RDEPENDS}"
DISTRO_EXTRA_RRECOMMENDS += " ${POKY_DEFAULT_EXTRA_RRECOMMENDS}"
+DISTROOVERRIDES .= ":openbmc-phosphor"
+
POKYQEMUDEPS = "${@bb.utils.contains("INCOMPATIBLE_LICENSE", "GPL-3.0", "", "packagegroup-core-device-devel",d)}"
DISTRO_EXTRA_RDEPENDS_append_qemuarm = " ${POKYQEMUDEPS}"
DISTRO_EXTRA_RDEPENDS_append_qemuarm64 = " ${POKYQEMUDEPS}"
@@ -93,7 +95,6 @@ DISTRO_FEATURES_BACKFILL_CONSIDERED = " \
"
DISTRO_FEATURES_OBMC = " \
- ipmi-fru \
obmc-host-ctl \
obmc-host-ipmi \
obmc-phosphor-chassis-mgmt \
@@ -106,8 +107,6 @@ DISTRO_FEATURES_DEFAULT = " \
avahi \
ipv4 \
ipv6 \
- ldap \
- libc-inet-anl \
pam \
slp \
systemd \
@@ -124,9 +123,6 @@ MACHINE_FEATURES += " \
DISTRO_EXTRA_RDEPENDS_remove_qemuarm = "packagegroup-core-device-devel"
-# TODO: openbmc/openbmc#12345 - Upgrade to pygobject-3.
-PREFERRED_VERSION_python-pygobject = "2.%"
-
include conf/distro/include/openbmc-phosphor/${MACHINE}.inc
KERNEL_FEATURES_append = " phosphor-gpio-keys"
@@ -146,3 +142,9 @@ BAD_RECOMMENDATIONS += "shared-mime-info"
LAYER_CONF_VERSION ?= "8"
KERNEL_CLASSES_append = " obmc-phosphor-kernel-version"
+
+# Some packages have directory trees of YAML files arranged based on
+# canonical organization names. 'xyz/openbmc_project' should be used
+# everywhere in phosphor, but some layers may append this with their
+# own organization(s).
+OBMC_ORG_YAML_SUBDIRS += " xyz/openbmc_project"
diff --git a/meta-phosphor/conf/distro/include/phosphor-mmc.inc b/meta-phosphor/conf/distro/include/phosphor-mmc.inc
new file mode 100644
index 000000000..05d79c71f
--- /dev/null
+++ b/meta-phosphor/conf/distro/include/phosphor-mmc.inc
@@ -0,0 +1,2 @@
+DISTRO_FEATURES += "phosphor-mmc"
+DISTROOVERRIDES .= ":df-phosphor-mmc"
diff --git a/meta-phosphor/conf/layer.conf b/meta-phosphor/conf/layer.conf
index 028c6e52e..2292acce9 100644
--- a/meta-phosphor/conf/layer.conf
+++ b/meta-phosphor/conf/layer.conf
@@ -8,7 +8,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "phosphor-layer"
BBFILE_PATTERN_phosphor-layer := "^${LAYERDIR}/"
LAYERVERSION_phosphor-layer = "1"
-LAYERSERIES_COMPAT_phosphor-layer = "warrior zeus dunfell"
+LAYERSERIES_COMPAT_phosphor-layer = "dunfell gatesgarth"
IMAGE_FEATURES[validitems] += "tools-profile"
diff --git a/meta-phosphor/conf/machine/include/ibm-power-cpu.inc b/meta-phosphor/conf/machine/include/ibm-power-cpu.inc
new file mode 100644
index 000000000..1ff6dd304
--- /dev/null
+++ b/meta-phosphor/conf/machine/include/ibm-power-cpu.inc
@@ -0,0 +1 @@
+MACHINEOVERRIDES =. "ibm-power-cpu:"
diff --git a/meta-phosphor/conf/machine/include/ibm-power10-cpu.inc b/meta-phosphor/conf/machine/include/ibm-power10-cpu.inc
new file mode 100644
index 000000000..7d518ddaa
--- /dev/null
+++ b/meta-phosphor/conf/machine/include/ibm-power10-cpu.inc
@@ -0,0 +1,2 @@
+MACHINEOVERRIDES =. "ibm-power10-cpu:"
+require conf/machine/include/ibm-power-cpu.inc
diff --git a/meta-phosphor/conf/machine/include/ibm-power8-cpu.inc b/meta-phosphor/conf/machine/include/ibm-power8-cpu.inc
new file mode 100644
index 000000000..8be9d5395
--- /dev/null
+++ b/meta-phosphor/conf/machine/include/ibm-power8-cpu.inc
@@ -0,0 +1,2 @@
+MACHINEOVERRIDES =. "ibm-power8-cpu:"
+require conf/machine/include/ibm-power-cpu.inc
diff --git a/meta-phosphor/conf/machine/include/ibm-power9-cpu.inc b/meta-phosphor/conf/machine/include/ibm-power9-cpu.inc
new file mode 100644
index 000000000..d92cbdf37
--- /dev/null
+++ b/meta-phosphor/conf/machine/include/ibm-power9-cpu.inc
@@ -0,0 +1,2 @@
+MACHINEOVERRIDES =. "ibm-power9-cpu:"
+require conf/machine/include/ibm-power-cpu.inc
diff --git a/meta-phosphor/conf/machine/include/obmc-bsp-common.inc b/meta-phosphor/conf/machine/include/obmc-bsp-common.inc
index 4bafeafce..8a3da1199 100644
--- a/meta-phosphor/conf/machine/include/obmc-bsp-common.inc
+++ b/meta-phosphor/conf/machine/include/obmc-bsp-common.inc
@@ -5,10 +5,23 @@
KERNEL_CLASSES ?= "kernel-fitimage"
KERNEL_IMAGETYPES ?= "fitImage"
+# Static images. This is the default if no other layout is specified.
+IMAGE_FSTYPES += "${@bb.utils.contains_any('DISTRO_FEATURES', \
+ 'obmc-ubi-fs phosphor-mmc', \
+ '', \
+ 'mtd-static mtd-static-tar mtd-static-alltar', d)}"
+
+# UBI images.
IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', \
'obmc-ubi-fs', \
'mtd-ubi mtd-ubi-tar', \
- 'mtd-static mtd-static-tar mtd-static-alltar', d)}"
+ '', d)}"
+
+# eMMC images.
+IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', \
+ 'phosphor-mmc', \
+ 'wic.xz mmc-ext4-tar', \
+ '', d)}"
INITRAMFS_CTYPE ?= "xz"
INITRAMFS_FSTYPES = "cpio.${INITRAMFS_CTYPE}"