summaryrefslogtreecommitdiff
path: root/meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend')
-rw-r--r--meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend b/meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
index 71e208cd4..88b386018 100644
--- a/meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
+++ b/meta-phosphor/nuvoton-layer/recipes-kernel/linux/linux-nuvoton_%.bbappend
@@ -2,3 +2,11 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://phosphor-gpio-keys.scc"
SRC_URI += "file://phosphor-gpio-keys.cfg"
+
+
+python () {
+ # OpenBMC loads in kernel features via other mechanisms so this check
+ # in the kernel-yocto.bbclass is not required
+ d.setVar("KERNEL_DANGLING_FEATURES_WARN_ONLY","1")
+}
+