summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools/python/python3_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-devtools/python/python3_%.bbappend')
-rw-r--r--meta-phosphor/recipes-devtools/python/python3_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-phosphor/recipes-devtools/python/python3_%.bbappend b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
index 324b28ce0..a2dafcf6c 100644
--- a/meta-phosphor/recipes-devtools/python/python3_%.bbappend
+++ b/meta-phosphor/recipes-devtools/python/python3_%.bbappend
@@ -1,12 +1,12 @@
inherit update-alternatives
-ALTERNATIVE_${PN}-core += "python"
+ALTERNATIVE:${PN}-core += "python"
ALTERNATIVE_LINK_NAME[python] = "${bindir}/python"
ALTERNATIVE_TARGET[python] = "${bindir}/python3"
# python3 takes up a lot of space that most embedded systems
# do not have, so remove some un-needed files from the rootfs
-do_install_append_class-target() {
+do_install:append:class-target() {
# Even though python3 is built with --without-ensurepip, it still installs
# a large, compressed version of pip. Remove it to free up the space.
rm -rf ${D}${libdir}/python${PYTHON_MAJMIN}/ensurepip