summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-devtools')
-rw-r--r--meta-phosphor/recipes-devtools/python/python-pytest_%.bbappend13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-devtools/python/python-pytest_%.bbappend b/meta-phosphor/recipes-devtools/python/python-pytest_%.bbappend
new file mode 100644
index 000000000..e8dd736ef
--- /dev/null
+++ b/meta-phosphor/recipes-devtools/python/python-pytest_%.bbappend
@@ -0,0 +1,13 @@
+# python-pytest installs /usr/bin/pytest for both python2 and python3,
+# which causes a bitbake QA failure. Remove it from installation for the
+# native target to avoid the collision.
+#
+# We don't currently use this as a target package and if we did, we shouldn't
+# install both python2 and python3 variants.
+#
+# Once we are done with python2, we can delete this.
+
+do_install_append_class-native() {
+ rm ${D}${bindir}/py.test
+ rm ${D}${bindir}/pytest
+}