summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-devtools')
-rw-r--r--meta-phosphor/recipes-devtools/python/pyphosphor_git.bb4
-rw-r--r--meta-phosphor/recipes-devtools/python/python-pygobject_2.28.7.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb b/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
index 1274c1240..a0383d5fd 100644
--- a/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
+++ b/meta-phosphor/recipes-devtools/python/pyphosphor_git.bb
@@ -7,8 +7,8 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit allarch
-inherit setuptools
-inherit python-dir
+inherit setuptools3
+inherit python3-dir
PACKAGE_BEFORE_PN = " \
${PN}-ns \
diff --git a/meta-phosphor/recipes-devtools/python/python-pygobject_2.28.7.bb b/meta-phosphor/recipes-devtools/python/python-pygobject_2.28.7.bb
index 73ac563dc..cf0eb5db5 100644
--- a/meta-phosphor/recipes-devtools/python/python-pygobject_2.28.7.bb
+++ b/meta-phosphor/recipes-devtools/python/python-pygobject_2.28.7.bb
@@ -34,7 +34,7 @@ S = "${WORKDIR}/pygobject-${PV}"
EXTRA_OECONF += "--disable-introspection"
-inherit autotools distutils-base pkgconfig
+inherit autotools distutils3-base pkgconfig
# necessary to let the call for python-config succeed
export BUILD_SYS