summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-devtools')
-rw-r--r--meta-phosphor/recipes-devtools/python/python_2.%.bbappend9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-devtools/python/python_2.%.bbappend b/meta-phosphor/recipes-devtools/python/python_2.%.bbappend
index 12e1955ae..500497318 100644
--- a/meta-phosphor/recipes-devtools/python/python_2.%.bbappend
+++ b/meta-phosphor/recipes-devtools/python/python_2.%.bbappend
@@ -16,9 +16,8 @@ FILES_${PN}-spwd= " \
# files are required. Only do this if the openbmc-phosphor-tiny
# distro feature is enabled
do_install_append_openbmc-phosphor-tiny() {
- find ${D}${libdir}/python${PYTHON_MAJMIN} -name \*.py -exec rm {} \;
- # This is a system configuration file generated during build time.
- # It's used in the yocto packaging process so it is required to
- # remain in the image.
- cp ${WORKDIR}/recipe-sysroot-native/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata.py ${D}${libdir}/python${PYTHON_MAJMIN}/
+ # The _sysconfigdata.py is a system configuration file generated
+ # during build time. It's used in the yocto packaging process so
+ # it is required to remain in the image.
+ find ${D}${libdir}/python${PYTHON_MAJMIN} -name \*.py ! -name _sysconfigdata.py -exec rm {} \;
}