summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb')
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb17
1 files changed, 11 insertions, 6 deletions
diff --git a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
index bf815ce03..9d89895b0 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
@@ -1,11 +1,20 @@
SUMMARY = "sdbus++ dbus API / binding generator"
DESCRIPTION = "Generates bindings against sdbusplus for dbus APIs"
-inherit autotools pkgconfig
-inherit obmc-phosphor-python3-autotools
+inherit setuptools3
include sdbusplus-rev.inc
+## The sdbusplus repository has an Apache LICENSE file, which we would
+## normally check here, but the python setup script is in a subdirectory
+## which requires us to set ${S} below. When we change ${S} from the root
+## of the repository, bitbake can no longer find the LICENSE file. Point
+## to the common Apache license file in poky's meta instead.
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+S="${WORKDIR}/git/tools"
+
# Provide these aliases temporarily until everyone can move over to the
# new package name.
PROVIDES_class-native += "sdbusplus-native"
@@ -24,8 +33,4 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-pyyaml \
"
-PACKAGECONFIG ??= "transaction"
-PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
-PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
-
BBCLASSEXTEND += "native nativesdk"