summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb')
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb26
1 files changed, 10 insertions, 16 deletions
diff --git a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
index 9cc4cdc3f..49e2f4af2 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
@@ -1,26 +1,20 @@
SUMMARY = "C++ bindings for systemd dbus APIs"
DESCRIPTION = "C++ bindings for systemd dbus APIs."
-inherit autotools pkgconfig
-inherit obmc-phosphor-python3-autotools
-
+inherit meson
+inherit python3native
include sdbusplus-rev.inc
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+S = "${WORKDIR}/git"
+
DEPENDS += " \
- autoconf-archive-native \
${PYTHON_PN}-inflection-native \
${PYTHON_PN}-mako-native \
${PYTHON_PN}-pyyaml-native \
+ boost \
+ googletest \
+ systemd \
"
-
-PACKAGECONFIG ??= "libsdbusplus transaction"
-PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
-PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
-
-# Remove unused sdbus++ contents (included in python3-sdbus++ package).
-do_install_append() {
- rm ${D}/${bindir}/sdbus++
- rmdir ${D}/${bindir} || true
- rm -rf ${D}/${PYTHON_SITEPACKAGES_DIR}
- rmdir ${D}/${libdir}/${PYTHON_DIR} || true
-}