summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-extended')
-rw-r--r--meta-phosphor/recipes-extended/pam/libpam_%.bbappend6
-rw-r--r--meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb2
-rw-r--r--meta-phosphor/recipes-extended/rsyslog/rsyslog_%.bbappend4
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb2
4 files changed, 7 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-extended/pam/libpam_%.bbappend b/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
index 8ed05f629..682f132b5 100644
--- a/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
+++ b/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += " file://pam.d/common-password \
file://pam.d/common-account \
@@ -6,14 +6,14 @@ SRC_URI += " file://pam.d/common-password \
file://pam.d/common-session \
"
-RDEPENDS_${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \
+RDEPENDS:${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \
${MLPREFIX}pam-plugin-tally2-${libpam_suffix} \
${MLPREFIX}pam-plugin-pwhistory-${libpam_suffix} \
${MLPREFIX}pam-plugin-succeed-if-${libpam_suffix} \
${MLPREFIX}pam-plugin-localuser-${libpam_suffix} \
"
-do_install_append() {
+do_install:append() {
# The libpam recipe will always add a pam_systemd.so line to
# common-session if systemd is enabled; however systemd only
# builds pam_systemd.so if logind is enabled, and we disable
diff --git a/meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb b/meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb
index 30bcf6afb..a2bcb909c 100644
--- a/meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb
+++ b/meta-phosphor/recipes-extended/pam/pam-ipmi_git.bb
@@ -16,7 +16,7 @@ inherit autotools pkgconfig
DEPENDS += "autoconf-archive-native"
DEPENDS += "openssl libpam"
-FILES_${PN} += " \
+FILES:${PN} += " \
${base_libdir}/security/ \
${sysconfdir}/key_file \
${sysconfdir}/ipmi_pass \
diff --git a/meta-phosphor/recipes-extended/rsyslog/rsyslog_%.bbappend b/meta-phosphor/recipes-extended/rsyslog/rsyslog_%.bbappend
index 0a2fb3334..f04f63dd2 100644
--- a/meta-phosphor/recipes-extended/rsyslog/rsyslog_%.bbappend
+++ b/meta-phosphor/recipes-extended/rsyslog/rsyslog_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += " \
file://rsyslog.conf \
@@ -10,7 +10,7 @@ PACKAGECONFIG ??= " \
${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
"
-do_install_append(){
+do_install:append(){
install -m 0644 -D ${WORKDIR}/server.conf \
${D}${sysconfdir}/rsyslog.d/server.conf
}
diff --git a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
index 6557a1d9a..e5dbf4b50 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
@@ -22,7 +22,7 @@ DEPENDS += " \
${PYTHON_PN}-pyyaml-native \
"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
${PYTHON_PN}-inflection \
${PYTHON_PN}-mako \
${PYTHON_PN}-pyyaml \