summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-extended')
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/python-sdbus++_git.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-extended/sdbusplus/python-sdbus++_git.bb b/meta-phosphor/recipes-extended/sdbusplus/python-sdbus++_git.bb
index 7bb0198a5..de4d6ba41 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/python-sdbus++_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/python-sdbus++_git.bb
@@ -7,3 +7,12 @@ SRC_URI += "file://0001-Revert-sdbus-switch-to-python3.patch"
# new package name.
PROVIDES_class-native += "sdbusplus-native sdbus++-native"
PROVIDES_class-nativesdk += "sdbusplus-nativesdk sdbus++-nativesdk"
+
+# If anyone wanted the sdbus++ executable, make them use the python3 version.
+# This avoids issues where both packages attempt to install the executable
+# into /usr/bin.
+DEPENDS += "python3-sdbus++-native"
+do_install_append() {
+ rm ${D}${bindir}/sdbus++
+ rmdir ${D}${bindir} || true
+}