summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-extended')
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb19
1 files changed, 10 insertions, 9 deletions
diff --git a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
index 5c285f247..a54ba6e49 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
@@ -11,14 +11,15 @@ inherit obmc-phosphor-python-autotools
DEPENDS += " \
autoconf-archive-native \
- python-inflection-native \
- python-mako-native \
- python-pyyaml-native \
+ ${PYTHON_PN}-inflection-native \
+ ${PYTHON_PN}-mako-native \
+ ${PYTHON_PN}-pyyaml-native \
"
RDEPENDS_sdbus++ += " \
- python-inflection \
- python-mako \
- python-pyyaml \
+ ${PYTHON_PN} \
+ ${PYTHON_PN}-inflection \
+ ${PYTHON_PN}-mako \
+ ${PYTHON_PN}-pyyaml \
"
# sdbus++ has a handful of runtime dependencies on other python packages.
@@ -31,9 +32,9 @@ RDEPENDS_sdbus++ += " \
# on sdbus++ runtime dependencies manually.
DEPENDS_append_class-native = " \
- python-inflection-native \
- python-mako-native \
- python-pyyaml-native \
+ ${PYTHON_PN}-inflection-native \
+ ${PYTHON_PN}-mako-native \
+ ${PYTHON_PN}-pyyaml-native \
"
SRC_URI += "git://github.com/openbmc/sdbusplus"