summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-extended')
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb17
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/sdbusplus-rev.inc4
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb5
3 files changed, 16 insertions, 10 deletions
diff --git a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
index bf815ce03..9d89895b0 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
@@ -1,11 +1,20 @@
SUMMARY = "sdbus++ dbus API / binding generator"
DESCRIPTION = "Generates bindings against sdbusplus for dbus APIs"
-inherit autotools pkgconfig
-inherit obmc-phosphor-python3-autotools
+inherit setuptools3
include sdbusplus-rev.inc
+## The sdbusplus repository has an Apache LICENSE file, which we would
+## normally check here, but the python setup script is in a subdirectory
+## which requires us to set ${S} below. When we change ${S} from the root
+## of the repository, bitbake can no longer find the LICENSE file. Point
+## to the common Apache license file in poky's meta instead.
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+S="${WORKDIR}/git/tools"
+
# Provide these aliases temporarily until everyone can move over to the
# new package name.
PROVIDES_class-native += "sdbusplus-native"
@@ -24,8 +33,4 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-pyyaml \
"
-PACKAGECONFIG ??= "transaction"
-PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd"
-PACKAGECONFIG[transaction] = "--enable-transaction,--disable-transaction"
-
BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus-rev.inc b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus-rev.inc
index 40a2c9e07..d66ceec70 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus-rev.inc
+++ b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus-rev.inc
@@ -1,10 +1,6 @@
HOMEPAGE = "http://github.com/openbmc/sdbusplus"
PR = "r1"
PV = "1.0+git${SRCPV}"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-
-S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/sdbusplus"
SRCREV = "3e71ab90ae1bfbc5cf2d4b632c2b29d49fe36c77"
diff --git a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
index 9cc4cdc3f..b9e17fc52 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
@@ -6,6 +6,11 @@ inherit obmc-phosphor-python3-autotools
include sdbusplus-rev.inc
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+S = "${WORKDIR}/git"
+
DEPENDS += " \
autoconf-archive-native \
${PYTHON_PN}-inflection-native \