summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-extended')
-rw-r--r--meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb2
-rw-r--r--meta-phosphor/recipes-extended/pam/libpam_%.bbappend1
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb5
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/sdbusplus-rev.inc2
-rw-r--r--meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb5
-rw-r--r--meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb2
-rw-r--r--meta-phosphor/recipes-extended/stdplus/stdplus_git.bb5
7 files changed, 13 insertions, 9 deletions
diff --git a/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb b/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
index 81f08f42c..cedae50c9 100644
--- a/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
+++ b/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
@@ -14,6 +14,6 @@ EXTRA_OEMESON = " \
"
SRC_URI += "git://github.com/openbmc/gpioplus"
-SRCREV = "d67babcdbe7854b14afb421861c25769519d0fc8"
+SRCREV = "2f8444ce2dfb265bc6dcd45cae0484d68f08dd91"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-extended/pam/libpam_%.bbappend b/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
index 07dd54847..8ed05f629 100644
--- a/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
+++ b/meta-phosphor/recipes-extended/pam/libpam_%.bbappend
@@ -10,6 +10,7 @@ RDEPENDS_${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \
${MLPREFIX}pam-plugin-tally2-${libpam_suffix} \
${MLPREFIX}pam-plugin-pwhistory-${libpam_suffix} \
${MLPREFIX}pam-plugin-succeed-if-${libpam_suffix} \
+ ${MLPREFIX}pam-plugin-localuser-${libpam_suffix} \
"
do_install_append() {
diff --git a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
index 9d89895b0..6557a1d9a 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/python3-sdbus++_git.bb
@@ -15,11 +15,6 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
S="${WORKDIR}/git/tools"
-# Provide these aliases temporarily until everyone can move over to the
-# new package name.
-PROVIDES_class-native += "sdbusplus-native"
-PROVIDES_class-nativesdk += "sdbusplus-nativesdk"
-
DEPENDS += " \
autoconf-archive-native \
${PYTHON_PN}-inflection-native \
diff --git a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus-rev.inc b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus-rev.inc
index 5096a05ec..76df354cf 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus-rev.inc
+++ b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus-rev.inc
@@ -3,4 +3,4 @@ PR = "r1"
PV = "1.0+git${SRCPV}"
SRC_URI += "git://github.com/openbmc/sdbusplus"
-SRCREV = "fa3137a78e952134559bf7c41c4f29fa4afabe02"
+SRCREV = "c67e1e8730a2d3dcb155b21ced735ee188e8ea7f"
diff --git a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
index 49e2f4af2..973a92f3d 100644
--- a/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
+++ b/meta-phosphor/recipes-extended/sdbusplus/sdbusplus_git.bb
@@ -18,3 +18,8 @@ DEPENDS += " \
googletest \
systemd \
"
+
+EXTRA_OEMESON += " \
+ -Dtests=disabled \
+ -Dexamples=disabled \
+ "
diff --git a/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb b/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb
index f5404ce9f..9befc924a 100644
--- a/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb
+++ b/meta-phosphor/recipes-extended/sdeventplus/sdeventplus_git.bb
@@ -20,6 +20,6 @@ EXTRA_OEMESON = " \
"
SRC_URI += "git://github.com/openbmc/sdeventplus"
-SRCREV = "b315a2ab41ab6408a2185162fdd56c836249abdc"
+SRCREV = "b0a0e4db4628e2bab502767aa08cf236a0d0bf5d"
S = "${WORKDIR}/git"
diff --git a/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb b/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
index 4c3822fe4..78c6cdb9a 100644
--- a/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
+++ b/meta-phosphor/recipes-extended/stdplus/stdplus_git.bb
@@ -8,12 +8,15 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
inherit meson pkgconfig
+DEPENDS += "fmt"
+DEPENDS += "span-lite"
+
EXTRA_OEMESON = " \
-Dexamples=false \
-Dtests=disabled \
"
SRC_URI += "git://github.com/openbmc/stdplus"
-SRCREV = "a2d67e20529a1f720c13586553ad2cec1451d5a8"
+SRCREV = "5f22a6c260295b5d8553d77893aba01684e4a72c"
S = "${WORKDIR}/git"