summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb b/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb
new file mode 100644
index 000000000..c0cea9cb8
--- /dev/null
+++ b/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Phosphor certificate manager configuration for a bmcweb service"
+
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/LICENSE;md5=19407077e42b1ba3d653da313f1f5b4e"
+
+RDEPENDS_${PN} = "phosphor-certificate-manager"
+
+inherit allarch
+
+SRC_URI = "file://env"
+
+do_install() {
+ install -D ${WORKDIR}/env ${D}/${sysconfdir}/default/obmc/cert/bmcweb
+}
+
+pkg_postinst_${PN}() {
+ LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@bmcweb.service"
+ TARGET="../phosphor-certificate-manager@.service"
+ mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
+ ln -s $TARGET $LINK
+}
+
+pkg_prerm_${PN}() {
+ LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@bmcweb.service"
+ rm $LINK
+}