summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
index 933d43119..d81780c38 100644
--- a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
+++ b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
@@ -7,13 +7,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/phosphor-buttons.git"
-SRCREV = "5ed4cc0f0947e589c430618c29bd474f0fce32b3"
+SRCREV = "703c7609353f707f5abb33f4ca726b1803463a92"
inherit cmake pkgconfig systemd
BUTTON_PACKAGES="${PN}-signals ${PN}-handler"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
PACKAGE_BEFORE_PN += "${BUTTON_PACKAGES}"
PACKAGECONFIG ??= "signals handler"
SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
@@ -21,11 +21,11 @@ SYSTEMD_PACKAGES = "${BUTTON_PACKAGES}"
PACKAGECONFIG[signals] = ",,gpioplus nlohmann-json,"
PACKAGECONFIG[handler] = ",,,phosphor-state-manager-chassis phosphor-state-manager-host"
-FILES_${PN}-signals = "${bindir}/buttons"
-SYSTEMD_SERVICE_${PN}-signals = "xyz.openbmc_project.Chassis.Buttons.service"
+FILES:${PN}-signals = "${bindir}/buttons"
+SYSTEMD_SERVICE:${PN}-signals = "xyz.openbmc_project.Chassis.Buttons.service"
-FILES_${PN}-handler = "${bindir}/button-handler"
-SYSTEMD_SERVICE_${PN}-handler = "phosphor-button-handler.service"
+FILES:${PN}-handler = "${bindir}/button-handler"
+SYSTEMD_SERVICE:${PN}-handler = "phosphor-button-handler.service"
DEPENDS += " \
systemd \