summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/chassis
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/chassis')
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/files/obmc-phosphor-chassisd.py29
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/files/obmc-phosphor-chassisd.service10
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-chassisd.bb13
4 files changed, 1 insertions, 53 deletions
diff --git a/meta-phosphor/recipes-phosphor/chassis/files/obmc-phosphor-chassisd.py b/meta-phosphor/recipes-phosphor/chassis/files/obmc-phosphor-chassisd.py
deleted file mode 100644
index a68f2e511..000000000
--- a/meta-phosphor/recipes-phosphor/chassis/files/obmc-phosphor-chassisd.py
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/usr/bin/env python
-
-# Contributors Listed Below - COPYRIGHT 2015
-# [+] International Business Machines Corp.
-#
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
-# implied. See the License for the specific language governing
-# permissions and limitations under the License.
-
-import time
-import sys
-import dbus
-import dbus.service
-import dbus.mainloop.glib
-
-if __name__ == '__main__':
- print "obmc-phosphor-chassisd starting..."
-
- while 1:
- time.sleep(5)
diff --git a/meta-phosphor/recipes-phosphor/chassis/files/obmc-phosphor-chassisd.service b/meta-phosphor/recipes-phosphor/chassis/files/obmc-phosphor-chassisd.service
deleted file mode 100644
index 2ca9fe327..000000000
--- a/meta-phosphor/recipes-phosphor/chassis/files/obmc-phosphor-chassisd.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Phosphor Chassis Controller
-
-[Service]
-Restart=always
-ExecStart=/usr/bin/env obmc-phosphor-chassisd
-SyslogIdentifier=obmc-phosphor-chassisd
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
index 894583173..933d43119 100644
--- a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
+++ b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-buttons_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/phosphor-buttons.git"
-SRCREV = "582b3f025a0ca424d07aee67185d51915bdf2f46"
+SRCREV = "5ed4cc0f0947e589c430618c29bd474f0fce32b3"
inherit cmake pkgconfig systemd
diff --git a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-chassisd.bb b/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-chassisd.bb
deleted file mode 100644
index d9dcd1af2..000000000
--- a/meta-phosphor/recipes-phosphor/chassis/obmc-phosphor-chassisd.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-SUMMARY = "Phosphor OpenBMC Chassis Management"
-DESCRIPTION = "Phosphor OpenBMC chassis management reference implementation."
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit obmc-phosphor-pydbus-service
-
-PROVIDES += "virtual/obmc-chassis-mgmt"
-RPROVIDES_${PN} += "virtual-obmc-chassis-mgmt"
-
-S = "${WORKDIR}"
-SRC_URI += "file://${BPN}.py"