summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
index f9887da38..e07140d11 100644
--- a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Entity Manager provides d-bus configuration data \
and configures system sensors"
SRC_URI = "git://github.com/openbmc/entity-manager.git file://blocklist.json"
-SRCREV = "ee70147add704c40e1999900ec8e67d1213729cc"
+SRCREV = "e7ac9c9eb1d2e4b052d7f9b082ab4642eab304e9"
PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
@@ -29,16 +29,16 @@ EXTRA_ENTITY_MANAGER_PACKAGES = " \
PACKAGE_BEFORE_PN = "${EXTRA_ENTITY_MANAGER_PACKAGES}"
-do_install_append() {
+do_install:append() {
install -D ${WORKDIR}/blocklist.json ${D}${datadir}/${BPN}/blacklist.json
}
-FILES_${PN} += " \
+FILES:${PN} += " \
${datadir}/dbus-1/system-services/xyz.openbmc_project.EntityManager.service \
"
-FILES_fru-device = "${bindir}/fru-device ${datadir}/${BPN}/blacklist.json"
+FILES:fru-device = "${bindir}/fru-device ${datadir}/${BPN}/blacklist.json"
SYSTEMD_PACKAGES = "${PN} ${EXTRA_ENTITY_MANAGER_PACKAGES}"
-SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service"
-SYSTEMD_SERVICE_fru-device = "xyz.openbmc_project.FruDevice.service"
-SYSTEMD_AUTO_ENABLE_fru-device_ibm-power-cpu = "disable"
+SYSTEMD_SERVICE:${PN} = "xyz.openbmc_project.EntityManager.service"
+SYSTEMD_SERVICE:fru-device = "xyz.openbmc_project.FruDevice.service"
+SYSTEMD_AUTO_ENABLE:fru-device_ibm-power-cpu = "disable"