summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
index d028e69ea..4162b2b58 100644
--- a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "Entity Manager"
DESCRIPTION = "Entity Manager provides d-bus configuration data \
and configures system sensors"
-SRC_URI = "git://github.com/openbmc/entity-manager.git"
+SRC_URI = "git://github.com/openbmc/entity-manager.git file://blocklist.json"
SRCREV = "1034e026001ceafb64d828622557af25e0fa5a38"
PV = "0.1+git${SRCPV}"
@@ -11,6 +11,7 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service \
${@bb.utils.contains('DISTRO_FEATURES', 'ipmi-fru', 'xyz.openbmc_project.FruDevice.service', '', d)}"
+SYSTEMD_AUTO_ENABLE_${PN}_ibm-power-cpu = "disable"
DEPENDS = "boost \
nlohmann-json \
@@ -24,3 +25,7 @@ EXTRA_OEMESON = "-Dtests=disabled"
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipmi-fru', d)}"
PACKAGECONFIG[ipmi-fru] = "-Dfru-device=true, -Dfru-device=false, i2c-tools,"
+
+do_install_append() {
+ install -D ${WORKDIR}/blocklist.json ${D}${datadir}/${BPN}/blacklist.json
+}