summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
index 25cd24a31..abe19d24e 100644
--- a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
@@ -3,23 +3,24 @@ DESCRIPTION = "Entity Manager provides d-bus configuration data \
and configures system sensors"
SRC_URI = "git://github.com/openbmc/entity-manager.git"
-SRCREV = "29d83258f1268b3c41f97649518fa9bb1ffe83ed"
+SRCREV = "ba5424ae0ae7bb76ee770068efbd05214a0e3b53"
PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service \
- xyz.openbmc_project.FruDevice.service"
+ ${@bb.utils.contains('DISTRO_FEATURES', 'ipmi-fru', 'xyz.openbmc_project.FruDevice.service', '', d)}"
DEPENDS = "boost \
- i2c-tools \
nlohmann-json \
sdbusplus \
valijson"
S = "${WORKDIR}/git/"
-inherit cmake systemd
+inherit meson systemd
-EXTRA_OECMAKE = "-DYOCTO=1"
+EXTRA_OEMESON = "-Dtests=disabled"
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipmi-fru', d)}"
+PACKAGECONFIG[ipmi-fru] = "-Dfru-device=true, -Dfru-device=false, i2c-tools,"