summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb32
1 files changed, 25 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
index 2746e6d67..0a5c099c2 100644
--- a/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
+++ b/meta-phosphor/recipes-phosphor/configuration/entity-manager_git.bb
@@ -2,25 +2,43 @@ SUMMARY = "Entity Manager"
DESCRIPTION = "Entity Manager provides d-bus configuration data \
and configures system sensors"
-SRC_URI = "git://github.com/openbmc/entity-manager.git"
-SRCREV = "8c505da0ffd8709f3c799a855ff921cfbd446201"
+SRC_URI = "git://github.com/openbmc/entity-manager.git file://blocklist.json"
+SRCREV = "9c7fd64642e4242d2422bd70abee04eda326e890"
PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b"
-SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service \
- ${@bb.utils.contains('DISTRO_FEATURES', 'ipmi-fru', 'xyz.openbmc_project.FruDevice.service', '', d)}"
-
DEPENDS = "boost \
+ dbus \
nlohmann-json \
sdbusplus \
valijson"
-S = "${WORKDIR}/git/"
+S = "${WORKDIR}/git"
inherit meson systemd
EXTRA_OEMESON = "-Dtests=disabled"
-PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipmi-fru', d)}"
+PACKAGECONFIG ??= "ipmi-fru"
PACKAGECONFIG[ipmi-fru] = "-Dfru-device=true, -Dfru-device=false, i2c-tools,"
+
+EXTRA_ENTITY_MANAGER_PACKAGES = " \
+ ${@bb.utils.contains('PACKAGECONFIG', 'ipmi-fru', 'fru-device', '', d)} \
+ "
+
+PACKAGE_BEFORE_PN = "${EXTRA_ENTITY_MANAGER_PACKAGES}"
+
+do_install_append() {
+ install -D ${WORKDIR}/blocklist.json ${D}${datadir}/${BPN}/blacklist.json
+}
+
+FILES_${PN} += " \
+ ${datadir}/dbus-1/system-services/xyz.openbmc_project.EntityManager.service \
+ "
+FILES_fru-device = "${bindir}/fru-device ${datadir}/${BPN}/blacklist.json"
+
+SYSTEMD_PACKAGES = "${PN} ${EXTRA_ENTITY_MANAGER_PACKAGES}"
+SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.EntityManager.service"
+SYSTEMD_SERVICE_fru-device = "xyz.openbmc_project.FruDevice.service"
+SYSTEMD_AUTO_ENABLE_fru-device_ibm-power-cpu = "disable"