summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb38
1 files changed, 23 insertions, 15 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
index 7338cf27d..e7090b146 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -6,25 +6,33 @@ S = "${WORKDIR}/git"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
-inherit autotools pkgconfig
-inherit python3native
+inherit meson
+inherit obmc-phosphor-utils
inherit phosphor-dbus-yaml
+inherit python3native
-DEPENDS += "autoconf-archive-native"
-DEPENDS += "${PYTHON_PN}-sdbus++-native"
+DEPENDS += " \
+ ${PYTHON_PN}-sdbus++-native \
+ sdbusplus \
+ systemd \
+ "
SRC_URI = "git://github.com/openbmc/phosphor-dbus-interfaces"
-SRCREV = "264d401d288841da24b9ce1377e3c399a2f4c60a"
+SRCREV = "d37091affcd933b7bc7cfd0ac393e2dd539f0235"
-PACKAGECONFIG ??= "libphosphor_dbus"
-PACKAGECONFIG[libphosphor_dbus] = " \
- --enable-libphosphor_dbus, \
- --disable-libphosphor_dbus, \
- systemd sdbusplus, \
- libsystemd \
- "
+# Process OBMC_ORG_YAML_SUBDIRS to create Meson config options.
+# ex. xyz/openbmc_project -> -Ddata_xyz_openbmc_project=true
+def pdi_meson_config(d):
+ return ' '.join([
+ '-Ddata_' + x.replace('/', '_') + '=true' \
+ for x in listvar_to_list(d, 'OBMC_ORG_YAML_SUBDIRS')
+ ])
+pdi_meson_config[vardeps] = "OBMC_ORG_YAML_SUBDIRS"
-PACKAGECONFIG_remove_class-native = "libphosphor_dbus"
-PACKAGECONFIG_remove_class-nativesdk = "libphosphor_dbus"
+# Markdown files are installed into /usr/share/phosphor-dbus-interfaces so
+# add them to the 'doc' subpackage.
+FILES_${PN}-doc += "${datadir}/${BPN}"
-BBCLASSEXTEND += "native nativesdk"
+EXTRA_OEMESON_append = " \
+ -Db_lto=true \
+ ${@pdi_meson_config(d)}"