summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
index 9e0e7c243..c4c7f51f8 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-mapper_git.bb
@@ -59,11 +59,23 @@ python do_emit_env() {
paths.append(os.sep.join(p.split('-')))
path = d.getVar('STAGING_DIR_NATIVE', True) + \
+ d.getVar('service_dir', True)
+ services = []
+ for s in os.listdir(path):
+ services.append('.'.join(s.split('-')))
+
+ path = d.getVar('STAGING_DIR_NATIVE', True) + \
d.getVar('interface_dir', True)
interfaces = []
for i in os.listdir(path):
interfaces.append('.'.join(i.split('-')))
+ path = d.getVar('STAGING_DIR_NATIVE', True) + \
+ d.getVar('serviceblacklist_dir', True)
+ service_blacklists = []
+ for x in os.listdir(path):
+ service_blacklists.append('.'.join(x.split('-')))
+
path = [d.getVar('D', True) + d.getVar('envfiledir', True)]
path.append('obmc')
path.append('mapper')
@@ -75,8 +87,12 @@ python do_emit_env() {
with open(path, 'w+') as fd:
fd.write('MAPPER_NAMESPACES="{}"'.format(' '.join(paths)))
fd.write('\n')
+ fd.write('MAPPER_SERVICES="{}"'.format(' '.join(services)))
+ fd.write('\n')
fd.write('MAPPER_INTERFACES="{}"'.format(' '.join(interfaces)))
fd.write('\n')
+ fd.write('MAPPER_SERVICEBLACKLISTS="{}"'.format(' '.join(service_blacklists)))
+ fd.write('\n')
}
do_install[postfuncs] += "do_emit_env"