summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dbus
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dbus')
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb2
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb (renamed from meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config-native.bb)5
-rw-r--r--meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb4
3 files changed, 6 insertions, 5 deletions
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
index 25e49ba34..12c5ee108 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-interfaces_git.bb
@@ -14,7 +14,7 @@ DEPENDS += "autoconf-archive-native"
DEPENDS += "sdbus++-native"
SRC_URI += "git://github.com/openbmc/phosphor-dbus-interfaces"
-SRCREV = "1f0e2ce6e1cb78a59a0015b160816b71156b03c6"
+SRCREV = "ddc9e9f9d6ed0282ec6c1421a706b45f3c09ebcc"
DEPENDS_remove_class-native = "sdbus++-native"
DEPENDS_remove_class-nativesdk = "sdbus++-native"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config-native.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb
index 80954f61f..6fadcae21 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config-native.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bb
@@ -1,12 +1,11 @@
SUMMARY = "Phosphor DBus Monitor Configuration"
-DESCRIPTION = "Meta-recipe, pulling in native recipes that wish to add \
+DESCRIPTION = "Meta-recipe, pulling in non-native recipes that wish to add \
configuration files to the /usr/share/phosphor-dbus-monitor filesystem."
HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
-inherit native
inherit phosphor-dbus-monitor
PHOSPHOR_DBUS_MONITOR_CONFIGS ??= ""
@@ -19,3 +18,5 @@ DEPENDS += "${PHOSPHOR_DBUS_MONITOR_CONFIGS}"
do_install() {
mkdir -p ${D}${config_dir}
}
+
+FILES_${PN} += "${config_dir}"
diff --git a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb
index 463bd8364..ae2274369 100644
--- a/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb
+++ b/meta-phosphor/recipes-phosphor/dbus/phosphor-dbus-monitor_git.bb
@@ -20,7 +20,7 @@ SYSTEMD_PACKAGES = "${PN} phosphor-msl-verify"
SYSTEMD_SERVICE_phosphor-msl-verify = "phosphor-msl-verify.service"
DEPENDS += " \
- ${PN}-config-native \
+ ${PN}-config \
phosphor-logging \
autoconf-archive-native \
sdbusplus-native \
@@ -34,5 +34,5 @@ FILES_phosphor-msl-verify = "${bindir}/phosphor-msl-verify"
S = "${WORKDIR}/git"
EXTRA_OECONF = " \
- YAML_PATH=${STAGING_DIR_NATIVE}${config_dir} \
+ YAML_PATH=${STAGING_DIR_HOST}${config_dir} \
"