summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb21
1 files changed, 12 insertions, 9 deletions
diff --git a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
index 7f05e75a9..8d74f39e0 100644
--- a/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
+++ b/meta-phosphor/recipes-phosphor/dump/phosphor-debug-collector_git.bb
@@ -20,8 +20,7 @@ DBUS_PACKAGES = "${PN}-manager"
SYSTEMD_PACKAGES = "${PN}-monitor"
-inherit autotools \
- pkgconfig \
+inherit meson \
obmc-phosphor-dbus-service \
python3native \
phosphor-debug-collector
@@ -30,7 +29,6 @@ require phosphor-debug-collector.inc
DEPENDS += " \
phosphor-dbus-interfaces \
- phosphor-dbus-interfaces-native \
phosphor-logging \
sdbusplus \
${PYTHON_PN}-sdbus++-native \
@@ -71,9 +69,9 @@ FILES_${PN}-scripts += "${dreport_dir}"
DBUS_SERVICE_${PN}-manager += "${MGR_SVC}"
SYSTEMD_SERVICE_${PN}-monitor += "obmc-dump-monitor.service"
-EXTRA_OECONF = " \
- BMC_DUMP_PATH=${bmc_dump_path} \
- ERROR_MAP_YAML=${STAGING_DIR_NATIVE}/${datadir}/dump/errors_watch.yaml \
+EXTRA_OEMESON = " \
+ -DBMC_DUMP_PATH=${bmc_dump_path} \
+ -DERROR_MAP_YAML=${STAGING_DIR_NATIVE}/${datadir}/dump/errors_watch.yaml \
"
S = "${WORKDIR}/git"
@@ -179,15 +177,20 @@ python install_dreport_user_scripts() {
#Enable ubifs-workaround by DISTRO_FEATURE obmc-ubi-fs.
PACKAGECONFIG_append_df-obmc-ubi-fs = " ubifs-workaround"
PACKAGECONFIG[ubifs-workaround] = " \
- --enable-ubifs-workaround, \
- --disable-ubifs-workaround \
+ -Dubifs-workaround=enabled, \
+ -Dubifs-workaround=disabled \
"
PACKAGECONFIG[host-dump-offload-pldm] = " \
- --with-host-dump-offload-transport=pldm,, \
+ -Dhost-dump-offload-transport=pldm,, \
pldm \
"
+PACKAGECONFIG[openpower-dumps-extension] = " \
+ -Dopenpower-dumps-extension=enabled, \
+ -Dopenpower-dumps-extension=disabled \
+"
+
do_install[postfuncs] += "install_dreport"
do_install[postfuncs] += "install_dreport_conf_file"
do_install[postfuncs] += "install_dreport_plugins_scripts"