summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans/files/Makefile')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/files/Makefile15
1 files changed, 0 insertions, 15 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/files/Makefile b/meta-phosphor/recipes-phosphor/fans/files/Makefile
deleted file mode 100644
index 10e3fa2ae..000000000
--- a/meta-phosphor/recipes-phosphor/fans/files/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-EXE = obmc-phosphor-fand
-OBJS = $(EXE).o
-DEPPKGS = gio-unix-2.0 glib-2.0
-CC ?= $(CROSS_COMPILE)gcc
-INCLUDES += $(shell pkg-config --cflags $(DEPPKGS))
-LIBS += $(shell pkg-config --libs $(DEPPKGS))
-
-%.o : %.c
- $(CC) -c $^ $(CFLAGS) $(INCLUDES) -o $@
-$(EXE): $(OBJS)
- $(CC) $^ $(LDFLAGS) $(LDFLAGS) -o $@
-clean:
- rm -f $(OBJS) $(EXE) *.o *.d
-distclean: clean
- rm -f *.c~ *.h~ *.sh~ Makefile~ config.mk~