summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans/files')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/files/Makefile15
-rw-r--r--meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.c29
-rw-r--r--meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.service10
3 files changed, 0 insertions, 54 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/files/Makefile b/meta-phosphor/recipes-phosphor/fans/files/Makefile
deleted file mode 100644
index 10e3fa2ae..000000000
--- a/meta-phosphor/recipes-phosphor/fans/files/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-EXE = obmc-phosphor-fand
-OBJS = $(EXE).o
-DEPPKGS = gio-unix-2.0 glib-2.0
-CC ?= $(CROSS_COMPILE)gcc
-INCLUDES += $(shell pkg-config --cflags $(DEPPKGS))
-LIBS += $(shell pkg-config --libs $(DEPPKGS))
-
-%.o : %.c
- $(CC) -c $^ $(CFLAGS) $(INCLUDES) -o $@
-$(EXE): $(OBJS)
- $(CC) $^ $(LDFLAGS) $(LDFLAGS) -o $@
-clean:
- rm -f $(OBJS) $(EXE) *.o *.d
-distclean: clean
- rm -f *.c~ *.h~ *.sh~ Makefile~ config.mk~
diff --git a/meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.c b/meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.c
deleted file mode 100644
index 558ba10bc..000000000
--- a/meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.c
+++ /dev/null
@@ -1,29 +0,0 @@
-/* Contributors Listed Below - COPYRIGHT 2015 */
-/* [+] International Business Machines Corp. */
-/* */
-/* */
-/* Licensed under the Apache License, Version 2.0 (the "License"); */
-/* you may not use this file except in compliance with the License. */
-/* You may obtain a copy of the License at */
-/* */
-/* http://www.apache.org/licenses/LICENSE-2.0 */
-/* */
-/* Unless required by applicable law or agreed to in writing, software */
-/* distributed under the License is distributed on an "AS IS" BASIS, */
-/* WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or */
-/* implied. See the License for the specific language governing */
-/* permissions and limitations under the License. */
-
-#include <stdio.h>
-#include <stdlib.h>
-#include <gio/gio.h>
-
-int main(int argc, char *argv[])
-{
- printf("obmc-phosphor-fand starting...\n");
-
- while(1)
- sleep(5);
-
- exit(EXIT_SUCCESS);
-}
diff --git a/meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.service b/meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.service
deleted file mode 100644
index a7d0b4b22..000000000
--- a/meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Phosphor Fan Controller
-
-[Service]
-Restart=always
-ExecStart=/usr/bin/env obmc-phosphor-fand
-SyslogIdentifier=obmc-phosphor-fand
-
-[Install]
-WantedBy=multi-user.target