summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
index 59579661b..8e2630ac5 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
@@ -7,14 +7,13 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
inherit flto-automake pkgconfig
-inherit pythonnative
inherit phosphor-pid-control
inherit obmc-phosphor-ipmiprovider-symlink
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
-SRCREV = "e6e6f62680cf77c0a742ca806609d10103273b07"
+SRCREV = "5782ab81367e22e87d719c9fef6e85ecdc6cf95e"
# Each platform will need a service file that starts
# at an appropriate time per system. For instance, if
@@ -22,10 +21,10 @@ SRCREV = "e6e6f62680cf77c0a742ca806609d10103273b07"
# sensors then it may be prudent to wait for all of them.
DEPENDS += "autoconf-archive-native"
-DEPENDS += "python-pyyaml-native"
-DEPENDS += "python-mako-native"
DEPENDS += "sdbusplus"
+DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "phosphor-logging"
+DEPENDS += "phosphor-dbus-interfaces"
DEPENDS += "libevdev"
DEPENDS += "nlohmann-json"
DEPENDS += "cli11"
@@ -33,9 +32,7 @@ DEPENDS += "cli11"
# We depend on this to be built first so we can build our providers.
DEPENDS += "phosphor-ipmi-host"
-RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
-
-FILES_${PN} = "${sbindir}/swampd ${sbindir}/setsensor"
+FILES_${PN} = "${bindir}/swampd ${bindir}/setsensor"
# The following installs the OEM IPMI handler for the fan controls.
FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"