summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/fans
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/fans')
-rw-r--r--meta-phosphor/recipes-phosphor/fans/files/Makefile15
-rw-r--r--meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.c29
-rw-r--r--meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.service10
-rw-r--r--meta-phosphor/recipes-phosphor/fans/obmc-phosphor-fand.bb17
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc2
-rw-r--r--meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb2
6 files changed, 2 insertions, 73 deletions
diff --git a/meta-phosphor/recipes-phosphor/fans/files/Makefile b/meta-phosphor/recipes-phosphor/fans/files/Makefile
deleted file mode 100644
index 10e3fa2ae..000000000
--- a/meta-phosphor/recipes-phosphor/fans/files/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-EXE = obmc-phosphor-fand
-OBJS = $(EXE).o
-DEPPKGS = gio-unix-2.0 glib-2.0
-CC ?= $(CROSS_COMPILE)gcc
-INCLUDES += $(shell pkg-config --cflags $(DEPPKGS))
-LIBS += $(shell pkg-config --libs $(DEPPKGS))
-
-%.o : %.c
- $(CC) -c $^ $(CFLAGS) $(INCLUDES) -o $@
-$(EXE): $(OBJS)
- $(CC) $^ $(LDFLAGS) $(LDFLAGS) -o $@
-clean:
- rm -f $(OBJS) $(EXE) *.o *.d
-distclean: clean
- rm -f *.c~ *.h~ *.sh~ Makefile~ config.mk~
diff --git a/meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.c b/meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.c
deleted file mode 100644
index 558ba10bc..000000000
--- a/meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.c
+++ /dev/null
@@ -1,29 +0,0 @@
-/* Contributors Listed Below - COPYRIGHT 2015 */
-/* [+] International Business Machines Corp. */
-/* */
-/* */
-/* Licensed under the Apache License, Version 2.0 (the "License"); */
-/* you may not use this file except in compliance with the License. */
-/* You may obtain a copy of the License at */
-/* */
-/* http://www.apache.org/licenses/LICENSE-2.0 */
-/* */
-/* Unless required by applicable law or agreed to in writing, software */
-/* distributed under the License is distributed on an "AS IS" BASIS, */
-/* WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or */
-/* implied. See the License for the specific language governing */
-/* permissions and limitations under the License. */
-
-#include <stdio.h>
-#include <stdlib.h>
-#include <gio/gio.h>
-
-int main(int argc, char *argv[])
-{
- printf("obmc-phosphor-fand starting...\n");
-
- while(1)
- sleep(5);
-
- exit(EXIT_SUCCESS);
-}
diff --git a/meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.service b/meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.service
deleted file mode 100644
index a7d0b4b22..000000000
--- a/meta-phosphor/recipes-phosphor/fans/files/obmc-phosphor-fand.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Phosphor Fan Controller
-
-[Service]
-Restart=always
-ExecStart=/usr/bin/env obmc-phosphor-fand
-SyslogIdentifier=obmc-phosphor-fand
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-phosphor/recipes-phosphor/fans/obmc-phosphor-fand.bb b/meta-phosphor/recipes-phosphor/fans/obmc-phosphor-fand.bb
deleted file mode 100644
index f7a3e051d..000000000
--- a/meta-phosphor/recipes-phosphor/fans/obmc-phosphor-fand.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "Phosphor OpenBMC Fan Management."
-DESCRIPTION = "Phosphor OpenBMC fan management reference implementation."
-PR = "r1"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-inherit pkgconfig
-inherit obmc-phosphor-sdbus-service
-inherit obmc-phosphor-c-daemon
-
-PROVIDES += "virtual/obmc-fan-mgmt"
-RPROVIDES_${PN} += "virtual-obmc-fan-mgmt"
-
-S = "${WORKDIR}"
-SRC_URI += "file://Makefile \
- file://obmc-phosphor-fand.c \
- "
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc b/meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc
index fe482caa1..ef9bee546 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-fan.inc
@@ -2,4 +2,4 @@ HOMEPAGE = "https://github.com/openbmc/phosphor-fan-presence"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
SRC_URI += "git://github.com/openbmc/phosphor-fan-presence"
-SRCREV = "f24d7749b3c65af3b76039fce729fe4ae278b892"
+SRCREV = "5e7298c58039b544ca917c27a01566fc28b18f0e"
diff --git a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
index 67bf6cca0..0f0c0a95b 100644
--- a/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
+++ b/meta-phosphor/recipes-phosphor/fans/phosphor-pid-control_git.bb
@@ -14,7 +14,7 @@ inherit systemd
S = "${WORKDIR}/git"
SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
-SRCREV = "298a95cbb192ecc678b1a496acc954a3b2adf450"
+SRCREV = "e30916c9ef6d363328b95c9947ac95d94a2b6a24"
# Each platform will need a service file that starts
# at an appropriate time per system. For instance, if