summaryrefslogtreecommitdiff
path: root/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb')
-rw-r--r--meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
index 81b51394c..ffe2f366e 100644
--- a/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
+++ b/meta-phosphor/recipes-phosphor/host/obmc-op-control-host_git.bb
@@ -8,13 +8,13 @@ inherit obmc-phosphor-dbus-service
inherit pkgconfig
PROVIDES += "virtual/obmc-host-ctl"
-RPROVIDES_${PN} += "virtual-obmc-host-ctl"
+RPROVIDES:${PN} += "virtual-obmc-host-ctl"
SKELETON_DIR = "op-hostctl"
FMT = "org.openbmc.control.Host@{0}.service"
-DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
-SYSTEMD_SERVICE_${PN} = " \
+DBUS_SERVICE:${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_SERVICE:${PN} = " \
op-start-host@.service \
"
@@ -23,4 +23,4 @@ START_TGTFMT = "obmc-host-startmin@{1}.target"
START_INSTFMT = "op-start-host@{0}.service"
START_FMT = "../${START_TMPL}:${START_TGTFMT}.requires/${START_INSTFMT}"
-SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"